summaryrefslogtreecommitdiff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
authorFelix Gruber <felgru@posteo.net>2021-12-18 13:36:54 +0000
committerLudovic Courtès <ludo@gnu.org>2022-01-20 15:28:14 +0100
commit8159cd08d2e6cfe6f0974e52f8a37ba19a623f13 (patch)
tree0ed4b5e95eb5c5e5eb7e67e765eb46e2e668e3c3 /gnu/packages/maths.scm
parent67e6b699165655d8d6258b37b8edf05800fb8e4b (diff)
downloadguix-patches-8159cd08d2e6cfe6f0974e52f8a37ba19a623f13.tar
guix-patches-8159cd08d2e6cfe6f0974e52f8a37ba19a623f13.tar.gz
gnu: dune-istl: Update to 2.7.1.
* gnu/packages/maths.scm (dune-istl): Update to 2.7.1. [arguments]: Parallelize build-tests phase. [source](patches) Remove patch that is no longer needed. * gnu/packages/patches/dune-istl-2.7-fix-non-mpi-tests.patch: Remove file. * gnu/local.mk (dist_patch_DATA): Remove above patch. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm13
1 files changed, 8 insertions, 5 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 92dabdba8e..8dc1c958e4 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -6526,7 +6526,7 @@ This package contains the basic DUNE grid classes.")
(define-public dune-istl
(package
(name "dune-istl")
- (version "2.7.0")
+ (version "2.7.1")
(source
(origin
(method url-fetch)
@@ -6534,8 +6534,7 @@ This package contains the basic DUNE grid classes.")
version "/dune-istl-" version ".tar.gz"))
(sha256
(base32
- "0gl3wgz5rs6sb4m83440ny45sbx7z7lnbi3gx6r9nm3rvy5j33f9"))
- (patches (search-patches "dune-istl-2.7-fix-non-mpi-tests.patch"))))
+ "1cy69s1266hvnh8blznlvvkrf8i2g640rc3mf7kp872wgvdz4nb9"))))
(build-system cmake-build-system)
(arguments
`(#:phases
@@ -6553,8 +6552,12 @@ This package contains the basic DUNE grid classes.")
":"))
#t)))
(add-after 'build 'build-tests
- (lambda* (#:key make-flags #:allow-other-keys)
- (apply invoke "make" "build_tests" make-flags))))))
+ (lambda* (#:key make-flags parallel-build? #:allow-other-keys)
+ (apply invoke "make" "build_tests"
+ `(,@(if parallel-build?
+ `("-j" ,(number->string (parallel-job-count)))
+ '())
+ ,@make-flags)))))))
(inputs
(list dune-common
;; Optional