summaryrefslogtreecommitdiff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
authorFelix Gruber <felgru@posteo.net>2021-12-18 13:36:53 +0000
committerLudovic Courtès <ludo@gnu.org>2022-01-20 15:28:14 +0100
commit67e6b699165655d8d6258b37b8edf05800fb8e4b (patch)
tree82b887187f0603acd63dcf9494cda45baa86f31c /gnu/packages/maths.scm
parent15ae25bd253575aae023fc3632e72e3bc64515ad (diff)
downloadguix-patches-67e6b699165655d8d6258b37b8edf05800fb8e4b.tar
guix-patches-67e6b699165655d8d6258b37b8edf05800fb8e4b.tar.gz
gnu: dune-grid: Update to 2.7.1.
* gnu/packages/maths.scm (dune-grid): Update to 2.7.1. [arguments]: Parallelize build-tests phase. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm12
1 files changed, 8 insertions, 4 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 6c92020565..92dabdba8e 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -6480,7 +6480,7 @@ This package contains the DUNE UG grid classes.")
(define-public dune-grid
(package
(name "dune-grid")
- (version "2.7.0")
+ (version "2.7.1")
(source
(origin
(method url-fetch)
@@ -6488,14 +6488,18 @@ This package contains the DUNE UG grid classes.")
version "/dune-grid-" version ".tar.gz"))
(sha256
(base32
- "17fjz30qazjgl11sryyxnw9klai4yz1ji4bs68013xcxc5hdv27s"))))
+ "15iws03hkbmr4a4rqqb0rriz1m8szl96wdr7gw0jmrcnlzbdbbx5"))))
(build-system cmake-build-system)
(arguments
`(#:phases
(modify-phases %standard-phases
(add-after 'build 'build-tests
- (lambda* (#:key make-flags #:allow-other-keys)
- (apply invoke "make" "build_tests" make-flags))))))
+ (lambda* (#:key make-flags parallel-build? #:allow-other-keys)
+ (apply invoke "make" "build_tests"
+ `(,@(if parallel-build?
+ `("-j" ,(number->string (parallel-job-count)))
+ '())
+ ,@make-flags)))))))
(inputs
(list dune-common
dune-geometry