summaryrefslogtreecommitdiff
path: root/gnu/packages/markup.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-10-07 14:50:20 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2020-10-08 15:57:33 +0200
commit34316794e73091e8920e54bd089616ad27fe107c (patch)
treeb6927ec783d581407a3e8e50934aacf2e25ac7cd /gnu/packages/markup.scm
parentf41b56a92e8158f1fcb4cfef762783a6bab8a63d (diff)
downloadguix-patches-34316794e73091e8920e54bd089616ad27fe107c.tar
guix-patches-34316794e73091e8920e54bd089616ad27fe107c.tar.gz
gnu: discount: Update to 2.2.7.
* gnu/packages/markup.scm (discount): Update to 2.2.7.
Diffstat (limited to 'gnu/packages/markup.scm')
-rw-r--r--gnu/packages/markup.scm18
1 files changed, 11 insertions, 7 deletions
diff --git a/gnu/packages/markup.scm b/gnu/packages/markup.scm
index 9569436729..9076bb77ed 100644
--- a/gnu/packages/markup.scm
+++ b/gnu/packages/markup.scm
@@ -3,7 +3,7 @@
;;; Copyright © 2015 David Thompson <davet@gnu.org>
;;; Copyright © 2016, 2019 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2017 Nikita <nikita@n0.is>
-;;; Copyright © 2017, 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2017, 2018, 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2020 Marius Bakke <mbakke@fastmail.com>
;;;
;;; This file is part of GNU Guix.
@@ -113,7 +113,7 @@ convert it to structurally valid XHTML (or HTML).")
(define-public discount
(package
(name "discount")
- (version "2.2.4")
+ (version "2.2.7")
(source (origin
(method url-fetch)
(uri (string-append
@@ -121,10 +121,11 @@ convert it to structurally valid XHTML (or HTML).")
"discount/discount-" version ".tar.bz2"))
(sha256
(base32
- "199hwajpspqil0a4y3yxsmhdp2dm73gqkzfk4mrwzsmlq8y1xzbl"))))
+ "024mxv0gpvilyfczarcgy5m7h4lv6qvhjfpf5i73qkxhszjjn9mi"))))
(build-system gnu-build-system)
(arguments
`(#:test-target "test"
+ #:parallel-build? #f ; libmarkdown won't be built in time
#:make-flags (list
(string-append "LFLAGS=-L. -Wl,-rpath="
(assoc-ref %outputs "out") "/lib"))
@@ -139,10 +140,13 @@ convert it to structurally valid XHTML (or HTML).")
#t))
(replace 'configure
(lambda* (#:key inputs outputs #:allow-other-keys)
- (setenv "CC" ,(cc-for-target))
- (invoke "./configure.sh"
- (string-append "--prefix=" (assoc-ref outputs "out"))
- "--shared"))))))
+ (let ((out (assoc-ref outputs "out")))
+ (setenv "CC" ,(cc-for-target))
+ ;; The ‘validate-runpath’ phase fails otherwise.
+ (setenv "LDFLAGS" (string-append "-Wl,-rpath=" out "/lib"))
+ (invoke "./configure.sh"
+ (string-append "--prefix=" out)
+ "--shared")))))))
(synopsis "Markdown processing library, written in C")
(description
"Discount is a markdown implementation, written in C. It provides a