summaryrefslogtreecommitdiff
path: root/gnu/packages/markup.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-10-07 14:46:54 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2020-10-08 15:57:32 +0200
commitf41b56a92e8158f1fcb4cfef762783a6bab8a63d (patch)
treebbb6d215fb4dfd8f9e0e0a40564b5589375c9f94 /gnu/packages/markup.scm
parent6ad8fc65d4baf5ac624021175dfa625c8fd35fd9 (diff)
downloadguix-patches-f41b56a92e8158f1fcb4cfef762783a6bab8a63d.tar
guix-patches-f41b56a92e8158f1fcb4cfef762783a6bab8a63d.tar.gz
gnu: discount: Cross-compile.
* gnu/packages/markup.scm (discount)[arguments]: Use CC-FOR-TARGET.
Diffstat (limited to 'gnu/packages/markup.scm')
-rw-r--r--gnu/packages/markup.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/markup.scm b/gnu/packages/markup.scm
index 56a920d873..9569436729 100644
--- a/gnu/packages/markup.scm
+++ b/gnu/packages/markup.scm
@@ -30,6 +30,7 @@
#:use-module (guix build-system trivial)
#:use-module (guix build-system cmake)
#:use-module (guix build-system perl)
+ #:use-module (guix utils)
#:use-module (gnu packages compression)
#:use-module (gnu packages)
#:use-module (gnu packages perl)
@@ -138,7 +139,7 @@ convert it to structurally valid XHTML (or HTML).")
#t))
(replace 'configure
(lambda* (#:key inputs outputs #:allow-other-keys)
- (setenv "CC" "gcc")
+ (setenv "CC" ,(cc-for-target))
(invoke "./configure.sh"
(string-append "--prefix=" (assoc-ref outputs "out"))
"--shared"))))))