summaryrefslogtreecommitdiff
path: root/gnu/packages/make-bootstrap.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-07-05 23:57:20 +0200
committerLudovic Courtès <ludo@gnu.org>2021-07-05 23:57:20 +0200
commitdbacdb8c03596c09e00a9f8627dae23aea7f30e4 (patch)
treebb703f2ab038e2ab99a9a39e8385ab99fcc9d72e /gnu/packages/make-bootstrap.scm
parent8740a62b6be3016a9dd0c61912152c69bdd4eb41 (diff)
downloadguix-patches-dbacdb8c03596c09e00a9f8627dae23aea7f30e4.tar
guix-patches-dbacdb8c03596c09e00a9f8627dae23aea7f30e4.tar.gz
gnu: bootstrap-tarballs: Turn builder into a gexp.
* gnu/packages/make-bootstrap.scm (%bootstrap-tarballs)[arguments]: Turn #:builder into a gexp.
Diffstat (limited to 'gnu/packages/make-bootstrap.scm')
-rw-r--r--gnu/packages/make-bootstrap.scm42
1 files changed, 21 insertions, 21 deletions
diff --git a/gnu/packages/make-bootstrap.scm b/gnu/packages/make-bootstrap.scm
index 196faad530..265884020e 100644
--- a/gnu/packages/make-bootstrap.scm
+++ b/gnu/packages/make-bootstrap.scm
@@ -23,6 +23,7 @@
;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
(define-module (gnu packages make-bootstrap)
+ #:use-module (guix gexp)
#:use-module (guix utils)
#:use-module (guix packages)
#:use-module (guix memoization)
@@ -878,27 +879,26 @@ for `sh' in $PATH, and without nscd, and with static NSS modules."
(source #f)
(build-system trivial-build-system)
(arguments
- `(#:modules ((guix build utils))
- #:builder
- (begin
- (use-modules (guix build utils)
- (ice-9 match)
- (srfi srfi-26))
-
- (define out (assoc-ref %outputs "out"))
-
- (setvbuf (current-output-port)
- (cond-expand (guile-2.0 _IOLBF) (else 'line)))
- (mkdir out)
- (chdir out)
- (for-each (match-lambda
- ((name . directory)
- (for-each (lambda (file)
- (format #t "~a -> ~a~%" file out)
- (symlink file (basename file)))
- (find-files directory "\\.tar\\."))))
- %build-inputs)
- #t)))
+ (list #:modules '((guix build utils))
+ #:builder
+ #~(begin
+ (use-modules (guix build utils)
+ (ice-9 match)
+ (srfi srfi-26))
+
+ (define out #$output)
+
+ (setvbuf (current-output-port)
+ (cond-expand (guile-2.0 _IOLBF) (else 'line)))
+ (mkdir out)
+ (chdir out)
+ (for-each (match-lambda
+ ((name . directory)
+ (for-each (lambda (file)
+ (format #t "~a -> ~a~%" file out)
+ (symlink file (basename file)))
+ (find-files directory "\\.tar\\."))))
+ %build-inputs))))
(inputs `(("guile-tarball" ,%guile-bootstrap-tarball)
,@(match (or (%current-target-system) (%current-system))
((or "i686-linux" "x86_64-linux")