summaryrefslogtreecommitdiff
path: root/gnu/packages/make-bootstrap.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-07-05 22:18:23 +0200
committerLudovic Courtès <ludo@gnu.org>2021-07-05 22:18:23 +0200
commit8740a62b6be3016a9dd0c61912152c69bdd4eb41 (patch)
tree023b49579ec9d9c1e6b115319a40b6a28b2f1f80 /gnu/packages/make-bootstrap.scm
parent6265c004cbac8bfe41e89f2d56635afeffed15e3 (diff)
downloadguix-patches-8740a62b6be3016a9dd0c61912152c69bdd4eb41.tar
guix-patches-8740a62b6be3016a9dd0c61912152c69bdd4eb41.tar.gz
gnu: bootstrap-tarballs: Fix build.
* gnu/packages/make-bootstrap.scm (%bootstrap-tarballs)[arguments]: Make 'use-modules' the first expression. Failing that, 'match' would not be properly expanded when running on Guile 3.0.
Diffstat (limited to 'gnu/packages/make-bootstrap.scm')
-rw-r--r--gnu/packages/make-bootstrap.scm6
1 files changed, 4 insertions, 2 deletions
diff --git a/gnu/packages/make-bootstrap.scm b/gnu/packages/make-bootstrap.scm
index 2cf7881bcf..196faad530 100644
--- a/gnu/packages/make-bootstrap.scm
+++ b/gnu/packages/make-bootstrap.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2012, 2013, 2014, 2015, 2016, 2017, 2018, 2019, 2020 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2012, 2013, 2014, 2015, 2016, 2017, 2018, 2019, 2020, 2021 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2017 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018, 2019 Mark H Weaver <mhw@netris.org>
@@ -880,11 +880,13 @@ for `sh' in $PATH, and without nscd, and with static NSS modules."
(arguments
`(#:modules ((guix build utils))
#:builder
- (let ((out (assoc-ref %outputs "out")))
+ (begin
(use-modules (guix build utils)
(ice-9 match)
(srfi srfi-26))
+ (define out (assoc-ref %outputs "out"))
+
(setvbuf (current-output-port)
(cond-expand (guile-2.0 _IOLBF) (else 'line)))
(mkdir out)