summaryrefslogtreecommitdiff
path: root/gnu/packages/make-bootstrap.scm
diff options
context:
space:
mode:
authorThiago Jung Bauermann <bauermann@kolabnow.com>2021-08-23 18:01:35 -0300
committerLudovic Courtès <ludo@gnu.org>2021-09-28 23:45:01 +0200
commit106181c0a0bc757b68eb683464ec8122a7d371db (patch)
tree51aa431ab7dd1587fbb085f86d9cc566fb084d08 /gnu/packages/make-bootstrap.scm
parent7d30e6e5c21f5e0b79f73428414fef2dbf75e7a6 (diff)
downloadguix-patches-106181c0a0bc757b68eb683464ec8122a7d371db.tar
guix-patches-106181c0a0bc757b68eb683464ec8122a7d371db.tar.gz
gnu: make-bootstrap: Enable tests in static gawk build.
The tests were disabled because gawk’s extension mechanism doesn’t work when it’s built statically, and some tests fail because of that. Another alternative is to disable the extension mechanism during configuration time, which causes the testsuite to pass again. * gnu/packages/make-bootstrap.scm (%static-inputs)[gawk]<#:tests?>: Remove. <#:configure-flags>: Add. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/make-bootstrap.scm')
-rw-r--r--gnu/packages/make-bootstrap.scm4
1 files changed, 3 insertions, 1 deletions
diff --git a/gnu/packages/make-bootstrap.scm b/gnu/packages/make-bootstrap.scm
index 40c1f82230..3fc5c2a62d 100644
--- a/gnu/packages/make-bootstrap.scm
+++ b/gnu/packages/make-bootstrap.scm
@@ -225,7 +225,9 @@ for `sh' in $PATH, and without nscd, and with static NSS modules."
;; plug-in mechanism just fail on static builds:
;;
;; ./fts.awk:1: error: can't open shared library `filefuncs' for reading (No such file or directory)
- #:tests? #f
+ ;;
+ ;; Therefore disable extensions support.
+ #:configure-flags (list "--disable-extensions")
,@(substitute-keyword-arguments (package-arguments gawk)
((#:phases phases)