summaryrefslogtreecommitdiff
path: root/gnu/packages/mail.scm
diff options
context:
space:
mode:
authorPhilip McGrath <philip@philipmcgrath.com>2021-11-20 00:43:53 -0500
committerLudovic Courtès <ludo@gnu.org>2021-12-10 15:32:45 +0100
commit7c2d84df1c05d41ba9eafb6f64abd694166e55c3 (patch)
tree9398c184eec82ca214016b673ba0b070eee38906 /gnu/packages/mail.scm
parent5cf2c889c9a6171451bc7aa8745076283653ab98 (diff)
downloadguix-patches-7c2d84df1c05d41ba9eafb6f64abd694166e55c3.tar
guix-patches-7c2d84df1c05d41ba9eafb6f64abd694166e55c3.tar.gz
gnu: sendgmail: Don't limit domain name of sender.
There are three open pull requests adding this functionality: - https://github.com/google/gmail-oauth2-tools/pull/17 (October 2019) - https://github.com/google/gmail-oauth2-tools/pull/26 (May 2020) - https://github.com/google/gmail-oauth2-tools/pull/37 (May 2021) (The patch here is identical to #26, so I just closed this one.) Meanwhile, the most recent commit to the upstream repository was in May 2019: that was the commit that first added `sendgmail`. This commit adjusts Guix's `sendgmail`, following Postel's advice, to make the command "liberal in its receiving behavior" (RFC 760): it always accepts email addresses with any domain name, as in #26, and it accepts (and ignores) the `-gsuite` flag used in #17. * gnu/packages/patches/sendgmail-remove-domain-restriction.patch: New file. This is the patch from #26. * gnu/packages/patches/sendgmail-accept-ignored-gsuite-flag.patch: New file, based on #17. * gnu/local.mk (dist_patch_DATA): Add the new patches. * gnu/packages/mail.scm (sendgmail)[source]: Apply the new patches. Increment the "revision" argument to `git-version` from 0 to 1. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/mail.scm')
-rw-r--r--gnu/packages/mail.scm11
1 files changed, 9 insertions, 2 deletions
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index b75c1a0965..e52b48a2d6 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -4661,7 +4661,7 @@ feeds, converts them into emails, and sends them.")
(define-public sendgmail
(let ((commit "e3229155a4037267ce40f1a3a681f53221aa4d8d")
- (revision "0"))
+ (revision "1"))
(package
(name "sendgmail")
(version (git-version "0.0.0" revision commit))
@@ -4672,6 +4672,9 @@ feeds, converts them into emails, and sends them.")
(url "https://github.com/google/gmail-oauth2-tools")
(commit commit)))
(file-name (git-file-name name version))
+ (patches (search-patches
+ "sendgmail-remove-domain-restriction.patch"
+ "sendgmail-accept-ignored-gsuite-flag.patch"))
(sha256
(base32
"1cxpkiaajhq1gjsg47r2b5xgck0r63pvkyrkm7af8c8dw7fyn64f"))))
@@ -4691,5 +4694,9 @@ feeds, converts them into emails, and sends them.")
"The @command{sendgmail} command provides a minimal sendmail-compatible
front-end that connects to Gmail using OAuth2. It is specifically designed
for use with @code{git send-email}. The command needs a Gmail API key to
-function.")
+function.
+
+Guix's version of @command{sendgmail} has been patched for compatibility with
+all known forks, including support for non-@code{@@gmail.com} email
+addresses.")
(license license:asl2.0))))