summaryrefslogtreecommitdiff
path: root/gnu/packages/mail.scm
diff options
context:
space:
mode:
authorPhilip McGrath <philip@philipmcgrath.com>2021-11-20 00:43:52 -0500
committerLudovic Courtès <ludo@gnu.org>2021-12-10 15:32:45 +0100
commit5cf2c889c9a6171451bc7aa8745076283653ab98 (patch)
treede2d792b22a70c2a902892d9add8a7c13851e248 /gnu/packages/mail.scm
parentf0adb870ac0ea70bf6fb7a68f8782833017342cd (diff)
downloadguix-patches-5cf2c889c9a6171451bc7aa8745076283653ab98.tar
guix-patches-5cf2c889c9a6171451bc7aa8745076283653ab98.tar.gz
gnu: sendgmail: Rename package to match command.
Suggested by Ludo’ in <https://issues.guix.gnu.org/50420#3>. * gnu/packages/golang.scm (go-github-com-google-gmail-oauth2-tools-go-sendgmail): Move to ... * gnu/packages/mail.scm (sendgmail): ... this variable. Change `propagated-inputs` to `inputs`. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/mail.scm')
-rw-r--r--gnu/packages/mail.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index 83ffb57645..b75c1a0965 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -43,6 +43,7 @@
;;; Copyright © 2021 Xinglu Chen <public@yoctocell.xyz>
;;; Copyright © 2021 Benoit Joly <benoit@benoitj.ca>
;;; Copyright © 2021 Morgan Smith <Morgan.J.Smith@outlook.com>
+;;; Copyright © 2021 Philip McGrath <philip@philipmcgrath.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -4657,3 +4658,38 @@ feeds, converts them into emails, and sends them.")
;; GPL version 2 or 3. NOT 2+.
(license (list license:gpl2
license:gpl3))))
+
+(define-public sendgmail
+ (let ((commit "e3229155a4037267ce40f1a3a681f53221aa4d8d")
+ (revision "0"))
+ (package
+ (name "sendgmail")
+ (version (git-version "0.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/google/gmail-oauth2-tools")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1cxpkiaajhq1gjsg47r2b5xgck0r63pvkyrkm7af8c8dw7fyn64f"))))
+ (inputs
+ `(("go-golang-org-x-oauth2" ,go-golang-org-x-oauth2)
+ ("go-cloud-google-com-go-compute-metadata"
+ ,go-cloud-google-com-go-compute-metadata)))
+ (build-system go-build-system)
+ (arguments
+ '(#:unpack-path "github.com/google/gmail-oauth2-tools"
+ #:import-path "github.com/google/gmail-oauth2-tools/go/sendgmail"))
+ (home-page
+ "https://github.com/google/gmail-oauth2-tools/tree/master/go/sendgmail")
+ (synopsis
+ "Sendmail-compatible tool for using Gmail with @code{git send-email}")
+ (description
+ "The @command{sendgmail} command provides a minimal sendmail-compatible
+front-end that connects to Gmail using OAuth2. It is specifically designed
+for use with @code{git send-email}. The command needs a Gmail API key to
+function.")
+ (license license:asl2.0))))