summaryrefslogtreecommitdiff
path: root/gnu/packages/lxqt.scm
diff options
context:
space:
mode:
authorMeiyo Peng <meiyo@riseup.net>2019-03-13 23:37:22 +0800
committerDanny Milosavljevic <dannym@scratchpost.org>2019-03-14 16:47:17 +0100
commit4625cc66bf4cbd13b7a933ef8e6ae6d2db66fe01 (patch)
tree49ee678315e0bd5d0e29fc088dfd20fd7252c3f0 /gnu/packages/lxqt.scm
parent39387425fd872d7e58014315ceb9d25b0f612df5 (diff)
downloadguix-patches-4625cc66bf4cbd13b7a933ef8e6ae6d2db66fe01.tar
guix-patches-4625cc66bf4cbd13b7a933ef8e6ae6d2db66fe01.tar.gz
gnu: lxqt-notificationd: Update to 0.14.1.
* gnu/packages/lxqt.scm (lxqt-notificationd): Update to 0.14.1. [arguments]: Remove #:configure-flags. <#:phases>[patch-translations-dir]: New phase. Signed-off-by: Danny Milosavljevic <dannym@scratchpost.org>
Diffstat (limited to 'gnu/packages/lxqt.scm')
-rw-r--r--gnu/packages/lxqt.scm15
1 files changed, 10 insertions, 5 deletions
diff --git a/gnu/packages/lxqt.scm b/gnu/packages/lxqt.scm
index 06c0907872..31686aa2da 100644
--- a/gnu/packages/lxqt.scm
+++ b/gnu/packages/lxqt.scm
@@ -458,14 +458,14 @@ as a whole and are not limited to distinct applications.")
(define-public lxqt-notificationd
(package
(name "lxqt-notificationd")
- (version "0.13.0")
+ (version "0.14.1")
(source
(origin
(method url-fetch)
(uri (string-append "https://github.com/lxqt/" name "/releases/download/"
version "/" name "-" version ".tar.xz"))
(sha256
- (base32 "1l0hdbvghyhqgvy4pih7rvz26bc6yc8a3l1bdj11hnkw62h1i7d6"))))
+ (base32 "1kiag3fcx12qmslln6x6lwvm4f1spymwf71389kdya3vwx7hkmcy"))))
(build-system cmake-build-system)
(inputs
`(("kwindowsystem" ,kwindowsystem)
@@ -479,9 +479,6 @@ as a whole and are not limited to distinct applications.")
("qttools" ,qttools)))
(arguments
'(#:tests? #f ; no test target
- #:configure-flags
- ;; TODO: prefetch translations files from 'lxqt-l10n'.
- '("-DPULL_TRANSLATIONS=NO")
#:phases
(modify-phases %standard-phases
(add-after 'unpack 'patch-source
@@ -489,6 +486,14 @@ as a whole and are not limited to distinct applications.")
(substitute* '("autostart/CMakeLists.txt")
(("DESTINATION \"\\$\\{LXQT_ETC_XDG_DIR\\}")
"DESTINATION \"etc/xdg"))
+ #t))
+ (add-after 'unpack 'patch-translations-dir
+ (lambda* (#:key outputs #:allow-other-keys)
+ (substitute* '("config/CMakeLists.txt"
+ "src/CMakeLists.txt")
+ (("\\$\\{LXQT_TRANSLATIONS_DIR\\}")
+ (string-append (assoc-ref outputs "out")
+ "/share/lxqt/translations")))
#t)))))
(home-page "https://lxqt.org/")
(synopsis "The LXQt notification daemon")