summaryrefslogtreecommitdiff
path: root/gnu/packages/lxqt.scm
diff options
context:
space:
mode:
authorMeiyo Peng <meiyo@riseup.net>2019-03-13 23:37:21 +0800
committerDanny Milosavljevic <dannym@scratchpost.org>2019-03-14 16:47:17 +0100
commit39387425fd872d7e58014315ceb9d25b0f612df5 (patch)
tree55def5d520dab0ddfbc6bc15d9608e011425cc07 /gnu/packages/lxqt.scm
parent2493df44042d2d0a3a71d69aefa746bcab679e4b (diff)
downloadguix-patches-39387425fd872d7e58014315ceb9d25b0f612df5.tar
guix-patches-39387425fd872d7e58014315ceb9d25b0f612df5.tar.gz
gnu: lxqt-globalkeys: Update to 0.14.1.
* gnu/packages/lxqt.scm (lxqt-globalkeys): Update to 0.14.1. [arguments]: Remove #:configure-flags. <#:phases>[patch-translations-dir]: New phase. Signed-off-by: Danny Milosavljevic <dannym@scratchpost.org>
Diffstat (limited to 'gnu/packages/lxqt.scm')
-rw-r--r--gnu/packages/lxqt.scm14
1 files changed, 9 insertions, 5 deletions
diff --git a/gnu/packages/lxqt.scm b/gnu/packages/lxqt.scm
index 2d042be9fe..06c0907872 100644
--- a/gnu/packages/lxqt.scm
+++ b/gnu/packages/lxqt.scm
@@ -410,14 +410,14 @@ configuration of both LXQt and the underlying operating system.")
(define-public lxqt-globalkeys
(package
(name "lxqt-globalkeys")
- (version "0.13.0")
+ (version "0.14.1")
(source
(origin
(method url-fetch)
(uri (string-append "https://github.com/lxqt/" name "/releases/download/"
version "/" name "-" version ".tar.xz"))
(sha256
- (base32 "1gyvcjbhi7zpvgz1sf773dv9gc35hx5fz023njp9r4vl0dpcavgd"))))
+ (base32 "0m6svwy20bfy9d21g5l0qzjndph3rd8zqagmqgdjzjhh3lxwrsrk"))))
(build-system cmake-build-system)
(inputs
`(("kwindowsystem" ,kwindowsystem)
@@ -432,9 +432,6 @@ configuration of both LXQt and the underlying operating system.")
("lxqt-build-tools" ,lxqt-build-tools)))
(arguments
'(#:tests? #f ; no tests
- #:configure-flags
- ;; TODO: prefetch translations files from 'lxqt-l10n'.
- '("-DPULL_TRANSLATIONS=NO")
#:phases
(modify-phases %standard-phases
(add-after 'unpack 'patch-source
@@ -443,6 +440,13 @@ configuration of both LXQt and the underlying operating system.")
"xdg/CMakeLists.txt")
(("DESTINATION \"\\$\\{LXQT_ETC_XDG_DIR\\}")
"DESTINATION \"etc/xdg"))
+ #t))
+ (add-after 'unpack 'patch-translations-dir
+ (lambda* (#:key outputs #:allow-other-keys)
+ (substitute* "config/CMakeLists.txt"
+ (("\\$\\{LXQT_TRANSLATIONS_DIR\\}")
+ (string-append (assoc-ref outputs "out")
+ "/share/lxqt/translations")))
#t)))))
(home-page "https://lxqt.org/")
(synopsis "Daemon used to register global keyboard shortcuts")