summaryrefslogtreecommitdiff
path: root/gnu/packages/lxqt.scm
diff options
context:
space:
mode:
authorMeiyo Peng <meiyo@riseup.net>2019-03-13 23:37:20 +0800
committerDanny Milosavljevic <dannym@scratchpost.org>2019-03-14 16:47:17 +0100
commit2493df44042d2d0a3a71d69aefa746bcab679e4b (patch)
tree78490145feeaa87a451fde5171795a100de4203c /gnu/packages/lxqt.scm
parent6a75a1a56114ca8f01b65648176441e470143eff (diff)
downloadguix-patches-2493df44042d2d0a3a71d69aefa746bcab679e4b.tar
guix-patches-2493df44042d2d0a3a71d69aefa746bcab679e4b.tar.gz
gnu: lxqt-config: Update to 0.14.1.
* gnu/packages/lxqt.scm (lxqt-config): Update to 0.14.1. [inputs]: Add eudev, libxi, xf86-input-libinput. [arguments]: Remove #:configure-flags. <#:phases>[patch-translations-dir]: New phase. Signed-off-by: Danny Milosavljevic <dannym@scratchpost.org>
Diffstat (limited to 'gnu/packages/lxqt.scm')
-rw-r--r--gnu/packages/lxqt.scm26
1 files changed, 20 insertions, 6 deletions
diff --git a/gnu/packages/lxqt.scm b/gnu/packages/lxqt.scm
index 0daa12ba06..2d042be9fe 100644
--- a/gnu/packages/lxqt.scm
+++ b/gnu/packages/lxqt.scm
@@ -350,25 +350,28 @@ the operating system LXQt is running on.")
(define-public lxqt-config
(package
(name "lxqt-config")
- (version "0.13.0")
+ (version "0.14.1")
(source
(origin
(method url-fetch)
(uri (string-append "https://github.com/lxqt/" name "/releases/download/"
version "/" name "-" version ".tar.xz"))
(sha256
- (base32 "0rizhl2v41kpgp57a61r6nmwcdw8nh9hprrrf33nfrdw8hpwxb95"))))
+ (base32 "16k36knv6d72gg8hp7423l3ic43y3l3zbaf3spqn2a354y30myrg"))))
(build-system cmake-build-system)
(inputs
- `(("kwindowsystem" ,kwindowsystem)
+ `(("eudev" ,eudev)
+ ("kwindowsystem" ,kwindowsystem)
("libkscreen" ,libkscreen)
("liblxqt" ,liblxqt)
("libqtxdg" ,libqtxdg)
("libxcursor" ,libxcursor)
+ ("libxi" ,libxi)
("qtbase" ,qtbase)
("qtsvg" ,qtsvg)
("qtx11extras" ,qtx11extras)
("solid" ,solid)
+ ("xf86-input-libinput" ,xf86-input-libinput)
("zlib" ,zlib)))
(native-inputs
`(("pkg-config" ,pkg-config)
@@ -376,9 +379,6 @@ the operating system LXQt is running on.")
("qttools" ,qttools)))
(arguments
'(#:tests? #f ; no tests
- #:configure-flags
- ;; TODO: prefetch translations files from 'lxqt-l10n'.
- '("-DPULL_TRANSLATIONS=NO")
#:phases
(modify-phases %standard-phases
(add-after 'unpack 'patch-source
@@ -386,6 +386,20 @@ the operating system LXQt is running on.")
(substitute* '("src/CMakeLists.txt")
(("DESTINATION \"\\$\\{LXQT_ETC_XDG_DIR\\}")
"DESTINATION \"etc/xdg"))
+ #t))
+ (add-after 'unpack 'patch-translations-dir
+ (lambda* (#:key outputs #:allow-other-keys)
+ (substitute* '("lxqt-config-file-associations/CMakeLists.txt"
+ "lxqt-config-brightness/CMakeLists.txt"
+ "lxqt-config-appearance/CMakeLists.txt"
+ "lxqt-config-locale/CMakeLists.txt"
+ "lxqt-config-monitor/CMakeLists.txt"
+ "lxqt-config-input/CMakeLists.txt"
+ "liblxqt-config-cursor/CMakeLists.txt"
+ "src/CMakeLists.txt")
+ (("\\$\\{LXQT_TRANSLATIONS_DIR\\}")
+ (string-append (assoc-ref outputs "out")
+ "/share/lxqt/translations")))
#t)))))
(home-page "https://lxqt.org")
(synopsis "Tools to configure LXQt and the underlying operating system")