summaryrefslogtreecommitdiff
path: root/gnu/packages/lua.scm
diff options
context:
space:
mode:
authorGreg Hogan <code@greghogan.com>2021-06-24 13:23:21 +0000
committerLudovic Courtès <ludo@gnu.org>2021-11-14 00:10:58 +0100
commit459d7cfbc4f4821b645e93149717d38b7a80135e (patch)
treeb702651efa49cf56f355fe6bc4c920c9ec30b311 /gnu/packages/lua.scm
parent357ecb777ea22d444ae4cec1705ad940b926ecc7 (diff)
downloadguix-patches-459d7cfbc4f4821b645e93149717d38b7a80135e.tar
guix-patches-459d7cfbc4f4821b645e93149717d38b7a80135e.tar.gz
gnu: fmt: Update to 8.0.1.
* gnu/packages/pretty-print.scm (fmt): Update to 8.0.1, (fmt-7): New variable. * gnu/packages/astronomy.scm (celestia)[inputs], gnu/packages/kodi.scm (kodi)[inputs], gnu/packages/lua.scm (emilua)[inputs]: Change to fmt-7. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/lua.scm')
-rw-r--r--gnu/packages/lua.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/lua.scm b/gnu/packages/lua.scm
index 0ecc91294f..e40d28a473 100644
--- a/gnu/packages/lua.scm
+++ b/gnu/packages/lua.scm
@@ -14,6 +14,7 @@
;;; Copyright © 2020 Simon South <simon@simonsouth.net>
;;; Copyright © 2020 Paul A. Patience <paul@apatience.com>
;;; Copyright © 2021 Vinícius dos Santos Oliveira <vini.ipsmaker@gmail.com>
+;;; Copyright © 2021 Greg Hogan <code@greghogan.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1141,7 +1142,7 @@ shell command executions.")
(inputs
`(("boost" ,boost)
("boost-static" ,boost-static)
- ("fmt" ,fmt)
+ ("fmt" ,fmt-7)
;; LuaJIT has a 2GiB addressing limit[1] that has been fixed on OpenResty
;; fork. Emilua is severely affected by this limit, so the upstream package
;; is avoided. Emilua also depends on the -DLUAJIT_ENABLE_LUA52COMPAT