summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGreg Hogan <code@greghogan.com>2021-06-24 13:23:21 +0000
committerLudovic Courtès <ludo@gnu.org>2021-11-14 00:10:58 +0100
commit459d7cfbc4f4821b645e93149717d38b7a80135e (patch)
treeb702651efa49cf56f355fe6bc4c920c9ec30b311
parent357ecb777ea22d444ae4cec1705ad940b926ecc7 (diff)
downloadguix-patches-459d7cfbc4f4821b645e93149717d38b7a80135e.tar
guix-patches-459d7cfbc4f4821b645e93149717d38b7a80135e.tar.gz
gnu: fmt: Update to 8.0.1.
* gnu/packages/pretty-print.scm (fmt): Update to 8.0.1, (fmt-7): New variable. * gnu/packages/astronomy.scm (celestia)[inputs], gnu/packages/kodi.scm (kodi)[inputs], gnu/packages/lua.scm (emilua)[inputs]: Change to fmt-7. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/astronomy.scm3
-rw-r--r--gnu/packages/kodi.scm3
-rw-r--r--gnu/packages/lua.scm3
-rw-r--r--gnu/packages/pretty-print.scm15
4 files changed, 19 insertions, 5 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index fc8959faad..f50276e5b0 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -7,6 +7,7 @@
;;; Copyright © 2020, 2021 Guillaume Le Vaillant <glv@posteo.net>
;;; Copyright © 2021 Sharlatan Hellseher <sharlatanus@gmail.com>
;;; Copyright © 2021 Vinicius Monego <monego@posteo.net>
+;;; Copyright © 2021 Greg Hogan <code@greghogan.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -582,7 +583,7 @@ any arbitrary astrometric projection defined in the WCS standard.")
;; maybe required?
("mesa" ,mesa)
;; optional: fmtlib, Eigen3;
- ("fmt" ,fmt)
+ ("fmt" ,fmt-7)
("eigen" ,eigen)
;; glut: for glut interface
("freeglut" ,freeglut)))
diff --git a/gnu/packages/kodi.scm b/gnu/packages/kodi.scm
index b3dc96f925..1e50624696 100644
--- a/gnu/packages/kodi.scm
+++ b/gnu/packages/kodi.scm
@@ -5,6 +5,7 @@
;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018, 2020 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
+;;; Copyright © 2021 Greg Hogan <code@greghogan.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -404,7 +405,7 @@ alternatives. In compilers, this can reduce the cascade of secondary errors.")
("ffmpeg" ,ffmpeg)
("flac" ,flac)
("flatbuffers" ,flatbuffers)
- ("fmt" ,fmt)
+ ("fmt" ,fmt-7)
("fontconfig" ,fontconfig)
("freetype" ,freetype)
("fribidi" ,fribidi)
diff --git a/gnu/packages/lua.scm b/gnu/packages/lua.scm
index 0ecc91294f..e40d28a473 100644
--- a/gnu/packages/lua.scm
+++ b/gnu/packages/lua.scm
@@ -14,6 +14,7 @@
;;; Copyright © 2020 Simon South <simon@simonsouth.net>
;;; Copyright © 2020 Paul A. Patience <paul@apatience.com>
;;; Copyright © 2021 Vinícius dos Santos Oliveira <vini.ipsmaker@gmail.com>
+;;; Copyright © 2021 Greg Hogan <code@greghogan.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1141,7 +1142,7 @@ shell command executions.")
(inputs
`(("boost" ,boost)
("boost-static" ,boost-static)
- ("fmt" ,fmt)
+ ("fmt" ,fmt-7)
;; LuaJIT has a 2GiB addressing limit[1] that has been fixed on OpenResty
;; fork. Emilua is severely affected by this limit, so the upstream package
;; is avoided. Emilua also depends on the -DLUAJIT_ENABLE_LUA52COMPAT
diff --git a/gnu/packages/pretty-print.scm b/gnu/packages/pretty-print.scm
index 1fc1441052..728f00f16e 100644
--- a/gnu/packages/pretty-print.scm
+++ b/gnu/packages/pretty-print.scm
@@ -168,14 +168,14 @@ different programming languages.")
(define-public fmt
(package
(name "fmt")
- (version "7.1.3")
+ (version "8.0.1")
(source
(origin
(method url-fetch)
(uri (string-append "https://github.com/fmtlib/fmt/releases/download/"
version "/fmt-" version ".zip"))
(sha256
- (base32 "17sc10hfg087z0s774lnn05wwy3bfzmcv7j448p92pr0s02cb62x"))))
+ (base32 "1gqmsk4r93x65cqs8w7zhfiv70w5fv8279nrblggqm4mmdpaa9x6"))))
(build-system cmake-build-system)
(arguments
'(#:configure-flags '("-DBUILD_SHARED_LIBS=ON")))
@@ -190,6 +190,17 @@ to @code{IOStreams}.")
;; The library is bsd-2, but documentation and tests include other licenses.
(license (list bsd-2 bsd-3 psfl))))
+(define-public fmt-7
+ (package (inherit fmt)
+ (version "7.1.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/fmtlib/fmt/releases/download/"
+ version "/fmt-" version ".zip"))
+ (sha256
+ (base32 "17sc10hfg087z0s774lnn05wwy3bfzmcv7j448p92pr0s02cb62x"))))))
+
(define-public fmt-for-irods
(package
(inherit fmt)