summaryrefslogtreecommitdiff
path: root/gnu/packages/libreoffice.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-01-02 23:22:58 +0100
committerMarius Bakke <mbakke@fastmail.com>2019-01-13 01:25:15 +0100
commit9c2094785d5077d82b8f238e4d7aaf372e61fd06 (patch)
treee8a6744d6e174cd033c889c4b3de3cf5927d4372 /gnu/packages/libreoffice.scm
parent7c3acfcb69c00bc59b5c8cb51540560042045043 (diff)
downloadguix-patches-9c2094785d5077d82b8f238e4d7aaf372e61fd06.tar
guix-patches-9c2094785d5077d82b8f238e4d7aaf372e61fd06.tar.gz
gnu: libetonyek: Adjust inputs.
* gnu/packages/libreoffice.scm (libetonyek)[native-inputs]: Remove LIBLANGTAG. Move GLM and MDDS to ... [inputs]: ... here. [propagated-inputs]: Add LIBLANGTAG and ZLIB.
Diffstat (limited to 'gnu/packages/libreoffice.scm')
-rw-r--r--gnu/packages/libreoffice.scm13
1 files changed, 7 insertions, 6 deletions
diff --git a/gnu/packages/libreoffice.scm b/gnu/packages/libreoffice.scm
index cd300b05f4..2cbb0ca2e5 100644
--- a/gnu/packages/libreoffice.scm
+++ b/gnu/packages/libreoffice.scm
@@ -413,16 +413,17 @@ CorelDRAW documents of all versions.")
(native-inputs
`(("cppunit" ,cppunit)
("doxygen" ,doxygen)
- ("glm" ,glm)
("gperf" ,gperf)
- ("liblangtag" ,liblangtag)
- ("mdds" ,mdds)
("pkg-config" ,pkg-config)))
(propagated-inputs ; in Requires or Requires.private field of .pkg
- `(("librevenge" ,librevenge)
- ("libxml2" ,libxml2)))
+ `(("liblangtag" ,liblangtag)
+ ("librevenge" ,librevenge)
+ ("libxml2" ,libxml2)
+ ("zlib" ,zlib)))
(inputs
- `(("boost" ,boost)))
+ `(("boost" ,boost)
+ ("glm" ,glm)
+ ("mdds" ,mdds)))
(home-page "https://wiki.documentfoundation.org/DLP/Libraries/libetonyek")
(synopsis "Library for parsing the Apple Keynote format")
(description "Libetonyek is a library that parses the file format of