summaryrefslogtreecommitdiff
path: root/gnu/packages/libreoffice.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-06-07 09:36:48 +0200
committerRicardo Wurmus <rekado@elephly.net>2018-06-07 11:09:54 +0200
commit4e4dcd476eb8d234ab18e49a283f1a5631157183 (patch)
tree43b0b9fb309a30106dbe8f05257301ca2757a475 /gnu/packages/libreoffice.scm
parent38be0f4245d65e18e7d31f8207c99f8d0c674b5d (diff)
downloadguix-patches-4e4dcd476eb8d234ab18e49a283f1a5631157183.tar
guix-patches-4e4dcd476eb8d234ab18e49a283f1a5631157183.tar.gz
gnu: Add libqxp.
* gnu/packages/libreoffice.scm (libqxp): New variable.
Diffstat (limited to 'gnu/packages/libreoffice.scm')
-rw-r--r--gnu/packages/libreoffice.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/libreoffice.scm b/gnu/packages/libreoffice.scm
index a34f4ee7ff..de73930466 100644
--- a/gnu/packages/libreoffice.scm
+++ b/gnu/packages/libreoffice.scm
@@ -864,6 +864,33 @@ and to return information on pronunciations, meanings and synonyms.")
(license (non-copyleft "file://COPYING"
"See COPYING in the distribution."))))
+(define-public libqxp
+ (package
+ (name "libqxp")
+ (version "0.0.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://dev-www.libreoffice.org/src/libqxp/"
+ "libqxp-" version ".tar.xz"))
+ (sha256
+ (base32
+ "0wswz49y0lqwqw2nj9j7jaj5ag88hapcz8czgkxax57zhihpy9cc"))))
+ (build-system gnu-build-system)
+ (inputs
+ `(("boost" ,boost)
+ ("icu4c" ,icu4c)
+ ("zlib" ,zlib)))
+ (native-inputs
+ `(("cppunit" ,cppunit)
+ ("pkg-config" ,pkg-config)))
+ (propagated-inputs
+ `(("librevenge" ,librevenge))) ; mentioned in Requires field
+ (home-page "https://www.libreoffice.org")
+ (synopsis "Library and tools for the QuarkXPress file format")
+ (description "libqxp is a library and a set of tools for reading and
+converting QuarkXPress file format. It supports versions 3.1 to 4.1.")
+ (license mpl2.0)))
+
(define-public libreoffice
(package
(name "libreoffice")