summaryrefslogtreecommitdiff
path: root/gnu/packages/libreoffice.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-06-07 08:30:41 +0200
committerRicardo Wurmus <rekado@elephly.net>2018-06-07 11:09:54 +0200
commit38be0f4245d65e18e7d31f8207c99f8d0c674b5d (patch)
treee121d7cf855f3c89b16895533a0cc63b4a93ee08 /gnu/packages/libreoffice.scm
parentd6dd64af3743934402616a5fda3f93e3a14a3ab0 (diff)
downloadguix-patches-38be0f4245d65e18e7d31f8207c99f8d0c674b5d.tar
guix-patches-38be0f4245d65e18e7d31f8207c99f8d0c674b5d.tar.gz
gnu: Add libepubgen.
* gnu/packages/libreoffice.scm (libepubgen): New variable.
Diffstat (limited to 'gnu/packages/libreoffice.scm')
-rw-r--r--gnu/packages/libreoffice.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/libreoffice.scm b/gnu/packages/libreoffice.scm
index 1faab302a0..a34f4ee7ff 100644
--- a/gnu/packages/libreoffice.scm
+++ b/gnu/packages/libreoffice.scm
@@ -9,6 +9,7 @@
;;; Copyright © 2017, 2018 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2017, 2018 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2017 Rutger Helling <rhelling@mykolab.com>
+;;; Copyright © 2018 Ricardo Wurmus <rekado@elephly.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -224,6 +225,34 @@ cellphones), TCR (simple compressed text format), TealDoc, zTXT,
ZVR (simple compressed text format).")
(license mpl2.0)))
+(define-public libepubgen
+ (package
+ (name "libepubgen")
+ (version "0.1.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/libepubgen/libepubgen-"
+ version "/libepubgen-" version ".tar.xz"))
+ (sha256
+ (base32
+ "1b8mc9zzrqypj1v9zdy3ybc48pw0rfr06cyi7n6grvybjjwq9q03"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("cppunit" ,cppunit)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("libxml2" ,libxml2)
+ ("boost" ,boost)))
+ (propagated-inputs ; in Requires field of .pkg
+ `(("librevenge" ,librevenge)))
+ (home-page "https://sourceforge.net/projects/libepubgen/")
+ (synopsis "EPUB generator library for librevenge")
+ (description "libepubgen is an EPUB generator for librevenge. It supports
+librevenge's text document interface and--currently in a very limited
+way--presentation and vector drawing interfaces.")
+ (license mpl2.0)))
+
(define-public libwpg
(package
(name "libwpg")