summaryrefslogtreecommitdiff
path: root/gnu/packages/libreoffice.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-08-08 14:51:38 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-08-08 15:13:44 +0300
commit0e66a66864bffdf618e13da8ce825a72154d16d7 (patch)
tree9cde4d185f00d2943aed4ecef757a8ae9f6c294c /gnu/packages/libreoffice.scm
parent08a9e49d023403122f2547d3841b37222ad88976 (diff)
downloadguix-patches-0e66a66864bffdf618e13da8ce825a72154d16d7.tar
guix-patches-0e66a66864bffdf618e13da8ce825a72154d16d7.tar.gz
gnu: libmspub: Add missing include.
* gnu/packages/libreoffice.scm (libmspub)[source]: Add snippet to add missing include header.
Diffstat (limited to 'gnu/packages/libreoffice.scm')
-rw-r--r--gnu/packages/libreoffice.scm10
1 files changed, 9 insertions, 1 deletions
diff --git a/gnu/packages/libreoffice.scm b/gnu/packages/libreoffice.scm
index d359388ba3..4ce833aa2c 100644
--- a/gnu/packages/libreoffice.scm
+++ b/gnu/packages/libreoffice.scm
@@ -592,7 +592,15 @@ Aldus/Macromedia/Adobe FreeHand documents.")
(uri (string-append "https://dev-www.libreoffice.org/src/" name "/"
name "-" version ".tar.xz"))
(sha256 (base32
- "1fhkn013gzg59f4z7rldpbi0nj7lgdqzxanspsqa6axvmahw2dpg"))))
+ "1fhkn013gzg59f4z7rldpbi0nj7lgdqzxanspsqa6axvmahw2dpg"))
+ (modules '((guix build utils)))
+ (snippet
+ '(begin
+ ;; This can be removed with the next release.
+ ;; https://gerrit.libreoffice.org/c/libmspub/+/73814
+ (substitute* "src/lib/MSPUBMetaData.h"
+ (("include <vector>" all)
+ (string-append all "\n#include <cstdint>")))))))
(build-system gnu-build-system)
(native-inputs
`(("doxygen" ,doxygen)