summaryrefslogtreecommitdiff
path: root/gnu/packages/libreoffice.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-08-08 14:43:34 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-08-08 15:13:32 +0300
commit08a9e49d023403122f2547d3841b37222ad88976 (patch)
tree043ef0e43f567327cfa736fa645275ff95b58167 /gnu/packages/libreoffice.scm
parentd30130bcd6c0dfff262d0bcf03175514391d9aa3 (diff)
downloadguix-patches-08a9e49d023403122f2547d3841b37222ad88976.tar
guix-patches-08a9e49d023403122f2547d3841b37222ad88976.tar.gz
gnu: libfreehand: Fix compiling with gcc-10.
* gnu/packages/libreoffice.scm (libfreehand)[arguments]: Add configure-flag to not treat warnings as errors.
Diffstat (limited to 'gnu/packages/libreoffice.scm')
-rw-r--r--gnu/packages/libreoffice.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/libreoffice.scm b/gnu/packages/libreoffice.scm
index 87a9494129..d359388ba3 100644
--- a/gnu/packages/libreoffice.scm
+++ b/gnu/packages/libreoffice.scm
@@ -553,7 +553,8 @@ library primarily intended for language guessing.")
"1b1lvqh68rwij1yvmxy02hsmh7i74ma5767mk8mg5nx6chajshhf"))))
(build-system gnu-build-system)
(arguments
- '(#:phases (modify-phases %standard-phases
+ '(#:configure-flags '("--disable-werror")
+ #:phases (modify-phases %standard-phases
(add-before 'build 'adjust-for-ICU-65
(lambda _
;; Fix build with ICU 65 and later. Taken from this