summaryrefslogtreecommitdiff
path: root/gnu/packages/language.scm
diff options
context:
space:
mode:
authorAlex Vong <alexvong1995@gmail.com>2019-08-08 14:00:36 +0800
committerAlex Vong <alexvong1995@gmail.com>2019-09-17 13:29:37 +0800
commite4f72a584bc23ad564b2ab2c0f4e71cc0edd41e2 (patch)
treef8d7912b1c8c354f68ad79683d04ffd21ecc094f /gnu/packages/language.scm
parentdd97a9c4da44d490ea440f2ad774254ee26b99ac (diff)
downloadguix-patches-e4f72a584bc23ad564b2ab2c0f4e71cc0edd41e2.tar
guix-patches-e4f72a584bc23ad564b2ab2c0f4e71cc0edd41e2.tar.gz
gnu: Add python2-tegaki-recognize.
* gnu/packages/language.scm (python2-tegaki-recognize): New variable.
Diffstat (limited to 'gnu/packages/language.scm')
-rw-r--r--gnu/packages/language.scm56
1 files changed, 55 insertions, 1 deletions
diff --git a/gnu/packages/language.scm b/gnu/packages/language.scm
index d12ca7451e..ad7cf2a4b3 100644
--- a/gnu/packages/language.scm
+++ b/gnu/packages/language.scm
@@ -35,8 +35,10 @@
#:use-module (guix build-system perl)
#:use-module (guix build-system python)
#:use-module ((guix licenses)
- #:select (bsd-3 gpl2 gpl2+ gpl3 gpl3+ perl-license zpl2.1))
+ #:select
+ (bsd-3 gpl2 gpl2+ gpl3 gpl3+ lgpl2.1 perl-license zpl2.1))
#:use-module (guix download)
+ #:use-module (guix git-download)
#:use-module (guix utils))
(define-public perl-lingua-en-findnumber
@@ -594,3 +596,55 @@ suitable for both the desktop and mobile devices.")
;; Files in gifenc/ are licensed under gpl3+ while other files are licensed
;; under gpl2+. Therefore, the combined work is licensed under gpl3+.
(license gpl3+)))
+
+(define-public python2-tegaki-recognize
+ (let ((commit "eceec69fe651d0733c8c8752dae569d2283d0f3c")
+ (revision "1"))
+ (package
+ (inherit python2-tegaki-tools)
+ (name "python2-tegaki-recognize")
+ ;; version copied from <https://github.com/tegaki/tegaki/releases>
+ (version (git-version "0.3.1" revision commit))
+ (source
+ (origin
+ ;; We use GIT-FETCH because 'tegaki-recognize.desktop.in' and
+ ;; 'tegaki-recognize.in' are missing in the tarball.
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/tegaki/tegaki.git")
+ (commit commit)))
+ (sha256
+ (base32
+ "09mw2if9p885phbgah5f95q3fwy7s5b46qlmpxqyzfcnj6g7afr5"))
+ (file-name (git-file-name name version))
+ (modules `((guix build utils)
+ (ice-9 ftw)
+ (srfi srfi-26)
+ ,@remove-pre-compiled-files-modules))
+ (snippet
+ `(begin
+ ;; remove unnecessary files with potentially different license
+ (for-each delete-file-recursively
+ (scandir "."
+ (negate (cut member <> '("tegaki-recognize"
+ "." "..")))))
+ ,(remove-pre-compiled-files "pyc")
+ #t))))
+ (arguments
+ (substitute-keyword-arguments (package-arguments python2-tegaki-tools)
+ ((#:phases _)
+ `(modify-phases %standard-phases
+ (add-after 'unpack 'chdir
+ (lambda _
+ (chdir "tegaki-recognize")
+ #t))
+ ;; 'setup.py' script does not support one of the Python build
+ ;; system's default flags, "--single-version-externally-managed"
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (invoke "python" "setup.py" "install"
+ (string-append "--prefix=" (assoc-ref outputs "out"))
+ "--root=/")
+ #t))))))
+ (synopsis "Chinese and Japanese Handwriting Recognition (Main program)")
+ (license gpl2+)))) ; all files