summaryrefslogtreecommitdiff
path: root/gnu/packages/language.scm
diff options
context:
space:
mode:
authorAlex Vong <alexvong1995@gmail.com>2019-08-08 13:56:56 +0800
committerAlex Vong <alexvong1995@gmail.com>2019-09-17 13:29:31 +0800
commitdd97a9c4da44d490ea440f2ad774254ee26b99ac (patch)
tree206d7aef5f0c14676fafc302b74166840289d760 /gnu/packages/language.scm
parent58ac928925f4593bfc45c723c2f5cd2d93ba995b (diff)
downloadguix-patches-dd97a9c4da44d490ea440f2ad774254ee26b99ac.tar
guix-patches-dd97a9c4da44d490ea440f2ad774254ee26b99ac.tar.gz
gnu: Add python2-tegaki-tools.
* gnu/packages/language.scm (python2-tegaki-tools): New variable.
Diffstat (limited to 'gnu/packages/language.scm')
-rw-r--r--gnu/packages/language.scm29
1 files changed, 28 insertions, 1 deletions
diff --git a/gnu/packages/language.scm b/gnu/packages/language.scm
index bc02ff9681..d12ca7451e 100644
--- a/gnu/packages/language.scm
+++ b/gnu/packages/language.scm
@@ -35,7 +35,7 @@
#:use-module (guix build-system perl)
#:use-module (guix build-system python)
#:use-module ((guix licenses)
- #:select (bsd-3 gpl2 gpl2+ gpl3 perl-license zpl2.1))
+ #:select (bsd-3 gpl2 gpl2+ gpl3 gpl3+ perl-license zpl2.1))
#:use-module (guix download)
#:use-module (guix utils))
@@ -567,3 +567,30 @@ suitable for both the desktop and mobile devices.")
("python2-tegaki-python" ,python2-tegaki-python)))
(synopsis "Chinese and Japanese Handwriting Recognition (Base UI library)")
(license gpl2+))) ; all files
+
+(define-public python2-tegaki-tools
+ (package
+ (inherit python2-tegaki-wagomu)
+ (name "python2-tegaki-tools")
+ (version "0.3.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (tegaki-release-uri "tegaki-tools" version))
+ (sha256
+ (base32
+ "0xxv97ggh2jgldw3r7y59lv3fhz733r6l7mdn6nh4m0gvb0ja971"))
+ (modules remove-pre-compiled-files-modules)
+ (snippet (remove-pre-compiled-files "pyc"))))
+ (arguments
+ (substitute-keyword-arguments (package-arguments python2-tegaki-wagomu)
+ ((#:phases _) '%standard-phases)))
+ (inputs
+ `(("python2-tegaki-pygtk" ,python2-tegaki-pygtk)))
+ ;; override inherited inputs
+ (native-inputs '())
+ (propagated-inputs '())
+ (synopsis "Chinese and Japanese Handwriting Recognition (Advanced tools)")
+ ;; Files in gifenc/ are licensed under gpl3+ while other files are licensed
+ ;; under gpl2+. Therefore, the combined work is licensed under gpl3+.
+ (license gpl3+)))