summaryrefslogtreecommitdiff
path: root/gnu/packages/kde-utils.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2019-12-04 00:08:55 +0100
committerHartmut Goebel <h.goebel@crazy-compilers.com>2019-12-23 18:24:59 +0100
commit17a1566f76403dcc0154782f5fc27db1be54dba6 (patch)
treed2b049d1c60219c854f9bdac8f369953a650a879 /gnu/packages/kde-utils.scm
parentf2353f56a2da236e5c1177599c9266bde9bcf4fd (diff)
downloadguix-patches-17a1566f76403dcc0154782f5fc27db1be54dba6.tar
guix-patches-17a1566f76403dcc0154782f5fc27db1be54dba6.tar.gz
gnu: Add sweeper.
* gnu/packages/kde-utils.scm (sweeper): New variable.
Diffstat (limited to 'gnu/packages/kde-utils.scm')
-rw-r--r--gnu/packages/kde-utils.scm39
1 files changed, 39 insertions, 0 deletions
diff --git a/gnu/packages/kde-utils.scm b/gnu/packages/kde-utils.scm
index 55ebaef868..a7873b017f 100644
--- a/gnu/packages/kde-utils.scm
+++ b/gnu/packages/kde-utils.scm
@@ -496,3 +496,42 @@ Features:
@item Laptop support through the Solid hardware device framework
@end itemize")
(license license:gpl2+)))
+
+(define-public sweeper
+ (package
+ (name "sweeper")
+ (version "19.08.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://kde/stable/applications/" version
+ "/src/sweeper-" version ".tar.xz"))
+ (sha256
+ (base32 "1gn87yxmhi7rs82jq7y89bvlx33xbl9wq8kr96pcz423khqvjl84"))))
+ (properties `((tags . ("Desktop" "KDE" "Utilities"))))
+ (build-system qt-build-system)
+ (native-inputs
+ `(("extra-cmake-modules" ,extra-cmake-modules)
+ ("kdoctools" ,kdoctools)))
+ (inputs
+ `(("kactivities-stats" ,kactivities-stats)
+ ("kbookmarks" ,kbookmarks)
+ ("kcrash" ,kcrash)
+ ("kconfig" ,kconfig)
+ ("kconfigwidgets" ,kconfigwidgets)
+ ("kcoreaddons" ,kcoreaddons)
+ ("ki18n" ,ki18n)
+ ("kio" ,kio)
+ ("ktextwidgets" ,ktextwidgets)
+ ("kxmlgui" ,kxmlgui)
+ ("oxygen-icons" ,oxygen-icons) ;; default icon set
+ ("qtbase" ,qtbase)))
+ (home-page "https://kde.org/applications/utilities/org.kde.sweeper")
+ (synopsis "Temporary file and history cleaner")
+ (description "
+Sweeper helps to clean unwanted traces the user leaves on the system and to
+regain disk space removing unused temporary files.
+It can quickly remove temporary information, such as web page cookies,
+browser history, or the list of recently-opened documents. It helps provide
+additional privacy on a system shared between multiple users.")
+ (license license:lgpl2.0+ )))