summaryrefslogtreecommitdiff
path: root/gnu/packages/kde-utils.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2019-12-04 00:05:14 +0100
committerHartmut Goebel <h.goebel@crazy-compilers.com>2019-12-23 18:24:58 +0100
commitf2353f56a2da236e5c1177599c9266bde9bcf4fd (patch)
tree00717da73f2b24a7fafb779dd2b8ee550e13e40f /gnu/packages/kde-utils.scm
parent87f1b53221e5d0e0b3cd4dde0f7237563920eb9f (diff)
downloadguix-patches-f2353f56a2da236e5c1177599c9266bde9bcf4fd.tar
guix-patches-f2353f56a2da236e5c1177599c9266bde9bcf4fd.tar.gz
gnu: Add smb4k.
* gnu/packages/kde-utils.scm (smb4k): New variable.
Diffstat (limited to 'gnu/packages/kde-utils.scm')
-rw-r--r--gnu/packages/kde-utils.scm74
1 files changed, 74 insertions, 0 deletions
diff --git a/gnu/packages/kde-utils.scm b/gnu/packages/kde-utils.scm
index 699f1a9468..55ebaef868 100644
--- a/gnu/packages/kde-utils.scm
+++ b/gnu/packages/kde-utils.scm
@@ -27,6 +27,7 @@
#:use-module (gnu packages kde-frameworks)
#:use-module (gnu packages kde-plasma)
#:use-module (gnu packages qt)
+ #:use-module (gnu packages samba)
#:use-module (gnu packages xorg))
(define-public kate
@@ -422,3 +423,76 @@ result of working with a mouse and keyboard. This utility can be used to
remind you to take a break now and then.")
(license ;; GPL for programs, FDL for documentation
(list license:gpl2+ license:fdl1.2+))))
+
+(define-public smb4k
+ (package
+ (name "smb4k")
+ (version "3.0.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://sourceforge.net/projects/smb4k/files/"
+ version "/smb4k-" version ".tar.xz/download"))
+ (sha256
+ (base32 "1daajaj8qhxkzz8dsaracwi49z4i57466h6qnqnh2ir2l54q00ir"))))
+ (properties `((tags . ("Desktop" "KDE" "Utilities"))))
+ (build-system qt-build-system)
+ (native-inputs
+ `(("extra-cmake-modules" ,extra-cmake-modules)
+ ("kdoctools" ,kdoctools)))
+ (inputs
+ `(("kauth" ,kauth)
+ ("kconfig" ,kconfig)
+ ("kconfigwidgets" ,kconfigwidgets)
+ ("kcompletion" ,kcompletion)
+ ("kcoreaddons" ,kcoreaddons)
+ ("kcrash" ,kcrash)
+ ("kdbusaddons" ,kdbusaddons)
+ ("ki18n" ,ki18n)
+ ("kiconthemes" ,kiconthemes)
+ ("kio" ,kio)
+ ("kjobwidgets" ,kjobwidgets)
+ ("knotifications" ,knotifications)
+ ("knotifyconfig" ,knotifyconfig)
+ ("ktextwidgets" ,ktextwidgets)
+ ("kwallet" ,kwallet)
+ ("kwidgetsaddons" ,kwidgetsaddons)
+ ("kwindowsystem" ,kwindowsystem)
+ ("kxmlgui" ,kxmlgui)
+ ("libsmbclient" ,samba)
+ ("oxygen-icons" ,oxygen-icons) ;; default icon set
+ ("plasma-framework" ,plasma-framework)
+ ("qtbase" ,qtbase)
+ ("qtdeclarative" ,qtdeclarative)
+ ("solid" ,solid)))
+ (home-page "https://kde.org/applications/utilities/org.kde.smb4k")
+ (synopsis "Samba (SMB) share advanced browser")
+ (description "Smb4K is an network neighborhood browser for the KDE
+Software Compilation and a frontend to the programs of the Samba software
+suite.
+
+Features:
+@itemize
+@item Scanning for (active) workgroups, hosts, and shares
+@item Support of the CIFS (Linux) and SMBFS (FreeBSD) file system
+@item Mounting and unmounting of shares (using the KAuth framework)
+@item Access to the files of a mounted share using a file manager or terminal
+@item Auto-detection of external mounts and unmounts
+@item Remounting of previously used shares on program start
+@item Miscellaneous infos about remote network items and mounted shares
+@item Network search
+@item WINS server support
+@item Preview of the contents of a share
+@item Several methods to look up the initial list of workgroups and domains
+@item Default login
+@item Special handling of homes shares
+@item Ability to bookmark favorite shares and organize them in groups
+@item System tray widget
+@item Support of advanced Samba options
+@item Support of printer shares
+@item KWallet support
+@item Synchronization of a remote share with a local copy and vice versa
+@item Ability to define custom options for individual servers and shares
+@item Laptop support through the Solid hardware device framework
+@end itemize")
+ (license license:gpl2+)))