summaryrefslogtreecommitdiff
path: root/gnu/packages/kde-pim.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2019-12-05 20:09:50 +0100
committerHartmut Goebel <h.goebel@crazy-compilers.com>2020-02-03 14:27:23 +0100
commit8c71fd436347f5363e43387c4e3dc44f3c578d6e (patch)
treea4ab189ed30012af478647e13a749fa4caf36cc9 /gnu/packages/kde-pim.scm
parent68b1d81d53ba0992b65b9d084e9314038734ad88 (diff)
downloadguix-patches-8c71fd436347f5363e43387c4e3dc44f3c578d6e.tar
guix-patches-8c71fd436347f5363e43387c4e3dc44f3c578d6e.tar.gz
gnu: Add kpimtextedit.
* gnu/packages/kde-pim.scm (kpimtextedit): New variable.
Diffstat (limited to 'gnu/packages/kde-pim.scm')
-rw-r--r--gnu/packages/kde-pim.scm40
1 files changed, 40 insertions, 0 deletions
diff --git a/gnu/packages/kde-pim.scm b/gnu/packages/kde-pim.scm
index 0bbbf83988..e5744076c9 100644
--- a/gnu/packages/kde-pim.scm
+++ b/gnu/packages/kde-pim.scm
@@ -206,3 +206,43 @@ functions for accessing calendar data using the kcalcore API.")
(synopsis "Library for handling MIME data")
(description "A library for MIME handling.")
(license license:lgpl2.0+)))
+
+(define-public kpimtextedit
+ (package
+ (name "kpimtextedit")
+ (version "19.08.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://kde/stable/applications/" version
+ "/src/kpimtextedit-" version ".tar.xz"))
+ (sha256
+ (base32 "1as48j5qfpj9pqjck1615nlpk4a850m7xxcyl41gx8biww027zvm"))))
+ (build-system qt-build-system)
+ (native-inputs
+ `(("extra-cmake-modules" ,extra-cmake-modules)
+ ("qttools" ,qttools)))
+ (inputs
+ `(("grantlee" ,grantlee)
+ ("kcodecs" ,kcodecs)
+ ("kconfigwidgets" ,kconfigwidgets)
+ ("kcoreaddons" ,kcoreaddons)
+ ("kdesignerplugin" ,kdesignerplugin)
+ ("kemoticons" ,kemoticons)
+ ("ki18n" ,ki18n)
+ ("kiconthemes" ,kiconthemes)
+ ("kio" ,kio)
+ ("ksyntaxhighlighting" ,ksyntaxhighlighting)
+ ("ktextwidgets" ,ktextwidgets)
+ ("kwidgetsaddons" ,kwidgetsaddons)
+ ("kxmlgui" ,kxmlgui)
+ ("qtbase" ,qtbase)
+ ("qtspeech", qtspeech)
+ ("sonnet" ,sonnet)))
+ (arguments
+ `(#:tests? #f)) ;; TODO - test suite hangs
+ (home-page "https://api.kde.org/stable/kdepimlibs-apidocs/")
+ (synopsis "Library providing a textedit with PIM-specific features")
+ (description "A library for PIM-specific text editing utilities.")
+ (license ;; GPL for programs, LGPL for libraries, FDL for documentation
+ (list license:gpl2+ license:lgpl2.0+ license:fdl1.2+))))