summaryrefslogtreecommitdiff
path: root/gnu/packages/kde-pim.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2019-12-05 20:06:46 +0100
committerHartmut Goebel <h.goebel@crazy-compilers.com>2020-02-03 14:27:23 +0100
commit68b1d81d53ba0992b65b9d084e9314038734ad88 (patch)
treebab6e48972aac7543e02daa18cd29daf0d1c8397 /gnu/packages/kde-pim.scm
parent962b288ad5c117dfd924b38f808b50a6faf59dbf (diff)
downloadguix-patches-68b1d81d53ba0992b65b9d084e9314038734ad88.tar
guix-patches-68b1d81d53ba0992b65b9d084e9314038734ad88.tar.gz
gnu: Add kcalutils.
* gnu/packages/kde-pim.scm (kcalutils): New variable.
Diffstat (limited to 'gnu/packages/kde-pim.scm')
-rw-r--r--gnu/packages/kde-pim.scm39
1 files changed, 39 insertions, 0 deletions
diff --git a/gnu/packages/kde-pim.scm b/gnu/packages/kde-pim.scm
index be05abe386..0bbbf83988 100644
--- a/gnu/packages/kde-pim.scm
+++ b/gnu/packages/kde-pim.scm
@@ -111,6 +111,45 @@ This package contains the Akonadi PIM storage server and associated
programs.")
(license license:fdl1.2+)))
+(define-public kcalutils
+ (package
+ (name "kcalutils")
+ (version "19.08.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://kde/stable/applications/" version
+ "/src/kcalutils-" version ".tar.xz"))
+ (sha256
+ (base32 "1nlkik4qiciyh1slgpis3n5h9pks2ygdba9yq4s16nnmip4l45w2"))))
+ (build-system qt-build-system)
+ (native-inputs
+ `(("extra-cmake-modules" ,extra-cmake-modules)
+ ("libxml2" ,libxml2))) ;; xmllint required for tests
+ (inputs
+ `(("grantlee" ,grantlee)
+ ("kcalendarcore" ,kcalendarcore)
+ ("kcodecs" ,kcodecs)
+ ("kconfig" ,kconfig)
+ ("kconfigwidgets" ,kconfigwidgets)
+ ("kcoreaddons" ,kcoreaddons)
+ ("ki18n" ,ki18n)
+ ("kiconthemes" ,kiconthemes)
+ ("kidentitymanagement" ,kidentitymanagement)
+ ("kpimtextedit" ,kpimtextedit)
+ ("ktextwidgets" ,ktextwidgets)
+ ("kwidgetsaddons" ,kwidgetsaddons)
+ ("oxygen-icons" ,oxygen-icons) ; default icon set, required for tests
+ ("qtbase" ,qtbase)))
+ (arguments
+ `(#:tests? #f)) ;; TODO: seem to pull in some wrong theme
+ (home-page "https://api.kde.org/stable/kdepimlibs-apidocs/")
+ (synopsis "Library with utility functions for the handling of calendar
+data")
+ (description "This library provides a utility and user interface
+functions for accessing calendar data using the kcalcore API.")
+ (license license:lgpl2.0+)))
+
(define-public kmbox
(package
(name "kmbox")