summaryrefslogtreecommitdiff
path: root/gnu/packages/kde-frameworks.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2018-03-01 23:08:44 +0100
committerHartmut Goebel <h.goebel@crazy-compilers.com>2019-01-04 10:10:44 +0100
commit16b8aff85bcdb9799496c4a27257210cd45158e5 (patch)
tree9cb829d98ad3269b4d9b8d21d12d51d39b53093c /gnu/packages/kde-frameworks.scm
parentf8a0f3ac708359a72ca136e1c76dfc241a20ea90 (diff)
downloadguix-patches-16b8aff85bcdb9799496c4a27257210cd45158e5.tar
guix-patches-16b8aff85bcdb9799496c4a27257210cd45158e5.tar.gz
gnu: kinit: Use LIBRARY_PATH to search for dynamically loaded libs.
Transfer the NixOS "kdeinit-libpath" patch for kinit as of 2018-02-17. * gnu/packages/patches/kinit-kdeinit-libpath.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/kde-frameworks.scm (kinit)[source]: Use it.
Diffstat (limited to 'gnu/packages/kde-frameworks.scm')
-rw-r--r--gnu/packages/kde-frameworks.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index 7aae50f4bc..2d48661a44 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -2529,7 +2529,8 @@ in applications using the KDE Frameworks.")
"1rq9b59gdgcpvwd694l8h55sqahpdaky0n7ag5psjlfn5myf1d95"))
;; Use the store paths for other packages and dynamically loaded
;; libs
- (patches (search-patches "kinit-kdeinit-extra_libs.patch"))))
+ (patches (search-patches "kinit-kdeinit-extra_libs.patch"
+ "kinit-kdeinit-libpath.patch"))))
(build-system cmake-build-system)
(arguments
`(#:phases