summaryrefslogtreecommitdiff
path: root/gnu/packages/kde-frameworks.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2017-10-22 21:25:36 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2019-01-04 10:10:43 +0100
commitf8a0f3ac708359a72ca136e1c76dfc241a20ea90 (patch)
treed9896c4a28e84cc61c014ef7f1c3e39664c8da38 /gnu/packages/kde-frameworks.scm
parenta6e532815d5022d005a00f8323e46084cfa66221 (diff)
downloadguix-patches-f8a0f3ac708359a72ca136e1c76dfc241a20ea90.tar
guix-patches-f8a0f3ac708359a72ca136e1c76dfc241a20ea90.tar.gz
gnu: kinit: Use the store paths for dynamically loaded libs.
Transfer the NixOS "kdeinit-extra_libs" patch for kinit as of 2018-02-17. * gnu/packages/patches/kinit-kdeinit-extra_libs.patch: New filee. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/kde-frameworks.scm (kinit)[source]: Use it. <patch-paths>: New phase. [inputs]: Add kparts, plasma-framework.
Diffstat (limited to 'gnu/packages/kde-frameworks.scm')
-rw-r--r--gnu/packages/kde-frameworks.scm18
1 files changed, 17 insertions, 1 deletions
diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index 98c920aaa7..7aae50f4bc 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -2526,8 +2526,22 @@ in applications using the KDE Frameworks.")
name "-" version ".tar.xz"))
(sha256
(base32
- "1rq9b59gdgcpvwd694l8h55sqahpdaky0n7ag5psjlfn5myf1d95"))))
+ "1rq9b59gdgcpvwd694l8h55sqahpdaky0n7ag5psjlfn5myf1d95"))
+ ;; Use the store paths for other packages and dynamically loaded
+ ;; libs
+ (patches (search-patches "kinit-kdeinit-extra_libs.patch"))))
(build-system cmake-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-paths
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ ;; Set patched-in values:
+ (substitute* "src/kdeinit/kinit.cpp"
+ (("GUIX_PKGS_KF5_KIO") (assoc-ref inputs "kio"))
+ (("GUIX_PKGS_KF5_PARTS") (assoc-ref inputs "kparts"))
+ (("GUIX_PKGS_KF5_PLASMA") (assoc-ref inputs "plasma-framework")))
+ #t)))))
(native-inputs
`(("extra-cmake-modules" ,extra-cmake-modules)
("pkg-config" ,pkg-config)))
@@ -2545,11 +2559,13 @@ in applications using the KDE Frameworks.")
("kitemviews" ,kitemviews)
("ki18n" ,ki18n)
("kjobwidgets" ,kjobwidgets)
+ ("kparts" ,kparts)
("kservice" ,kservice)
("kwidgetsaddons" ,kwidgetsaddons)
("kwindowsystem" ,kwindowsystem)
("kxmlgui" ,kxmlgui)
("libcap" ,libcap) ; to install start_kdeinit with CAP_SYS_RESOURCE
+ ("plasma-framework" ,plasma-framework)
("qtbase" ,qtbase)
("solid" ,solid)))
(home-page "https://community.kde.org/Frameworks")