summaryrefslogtreecommitdiff
path: root/gnu/packages/julia-xyz.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-06-14 11:54:39 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-06-14 14:45:21 +0300
commitf9f98a2f066c5b02c14a48e0c2637d7eb4e7965d (patch)
tree625239ee9752143065f7f19f07e7e066c0c541b3 /gnu/packages/julia-xyz.scm
parentab7d4e851debba4db66a54294475b1a60185d265 (diff)
downloadguix-patches-f9f98a2f066c5b02c14a48e0c2637d7eb4e7965d.tar
guix-patches-f9f98a2f066c5b02c14a48e0c2637d7eb4e7965d.tar.gz
gnu: Add julia-functionwrappers.
* gnu/packages/julia-xyz.scm (julia-functionwrappers): New variable.
Diffstat (limited to 'gnu/packages/julia-xyz.scm')
-rw-r--r--gnu/packages/julia-xyz.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index e31b2d4199..84bba8575f 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -1296,6 +1296,34 @@ functions (or any callable object, really) using forward mode automatic
differentiation (AD).")
(license license:expat)))
+(define-public julia-functionwrappers
+ (package
+ (name "julia-functionwrappers")
+ (version "1.1.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/yuyichao/FunctionWrappers.jl")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "02jilpjr7px6138dx2w7ixricvfgsxqdk84d9dgviranibhnjcxa"))))
+ (build-system julia-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'adjust-tests
+ (lambda _
+ (substitute* "test/runtests.jl"
+ (("testset \\\"Abstract.*" all)
+ (string-append all "return\n"))))))))
+ (home-page "https://github.com/yuyichao/FunctionWrappers.jl")
+ (synopsis "Type stable and efficient wrapper of arbitrary functions")
+ (description "This package provides a type stable and efficient wrapper of
+arbitrary functions.")
+ (license license:expat)))
+
(define-public julia-fuzzycompletions
(package
(name "julia-fuzzycompletions")