summaryrefslogtreecommitdiff
path: root/gnu/packages/julia-xyz.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-06-14 11:43:52 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-06-14 14:45:21 +0300
commitab7d4e851debba4db66a54294475b1a60185d265 (patch)
tree7273df50b56e5b38a083c42bc8a6dc1c04c30e87 /gnu/packages/julia-xyz.scm
parent6ddeadbaf092b21c0131e23040e7bace5bb9264b (diff)
downloadguix-patches-ab7d4e851debba4db66a54294475b1a60185d265.tar
guix-patches-ab7d4e851debba4db66a54294475b1a60185d265.tar.gz
gnu: Add julia-recipespipeline.
* gnu/packages/julia-xyz.scm (julia-recipespipeline): New variable.
Diffstat (limited to 'gnu/packages/julia-xyz.scm')
-rw-r--r--gnu/packages/julia-xyz.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index dd847a3ed9..e31b2d4199 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -2545,6 +2545,37 @@ possible to describe visualization routines that can be used as components in
more complex visualizations.")
(license license:expat)))
+(define-public julia-recipespipeline
+ (package
+ (name "julia-recipespipeline")
+ (version "0.3.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/JuliaPlots/RecipesPipeline.jl")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0wa342m2d9k4kihr6g9i0wpbsipp0n11kh9jmlw4pc5msmz4rxr0"))))
+ (build-system julia-build-system)
+ (arguments
+ `(#:tests? #f)) ; Cycle with Plots.jl.
+ (propagated-inputs
+ `(("julia-nanmath" ,julia-nanmath)
+ ("julia-plotutils" ,julia-plotutils)
+ ("julia-recipesbase" ,julia-recipesbase)))
+ (home-page "http://juliaplots.org/RecipesPipeline.jl/dev/")
+ (synopsis "Utilities for processing recipes")
+ (description "This package was factored out of @code{Plots.jl} to allow any
+other plotting package to use the recipe pipeline. In short, the extremely
+lightweight @code{RecipesBase.jl} package can be depended on by any package to
+define \"recipes\": plot specifications of user-defined types, as well as custom
+plot types. @code{RecipePipeline.jl} contains the machinery to translate these
+recipes to full specifications for a plot.")
+ (license license:expat)))
+
(define-public julia-reexport
(package
(name "julia-reexport")