summaryrefslogtreecommitdiff
path: root/gnu/packages/julia-xyz.scm
diff options
context:
space:
mode:
authorjgart <jgart@dismail.de>2021-11-30 20:30:09 -0500
committerEfraim Flashner <efraim@flashner.co.il>2021-12-01 14:08:46 +0200
commitf303eaa31b554550b75e46b216d48ca38d0a4e70 (patch)
tree76d1a147b49f017585f464184717ebc4a2049178 /gnu/packages/julia-xyz.scm
parent2eca48e3101cfa7a787732d471a0b77fac07af07 (diff)
downloadguix-patches-f303eaa31b554550b75e46b216d48ca38d0a4e70.tar
guix-patches-f303eaa31b554550b75e46b216d48ca38d0a4e70.tar.gz
gnu: Add julia-jive.
* gnu/packages/julia-xyz.scm (julia-jive): New variable. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages/julia-xyz.scm')
-rw-r--r--gnu/packages/julia-xyz.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index ef9690262b..8449ddcd4b 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -2673,6 +2673,25 @@ extensions to the iterator interface.")
"Common functional iterator patterns (formerly @code{Iterators.jl}).")
(license license:expat)))
+(define-public julia-jive
+ (package
+ (name "julia-jive")
+ (version "0.2.20")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/wookay/Jive.jl")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0khwsdh8472jxcfi9lqw14l49sqlbsixql1jb4irnyajxkdjrcsf"))))
+ (build-system julia-build-system)
+ (home-page "https://github.com/wookay/Jive.jl")
+ (synopsis "Julia package to help with writing tests")
+ (description "@code{Jive.jl} is a Julia package to help with writing tests.")
+ (license license:expat)))
+
(define-public julia-json
(package
(name "julia-json")