summaryrefslogtreecommitdiff
path: root/gnu/packages/julia-xyz.scm
diff options
context:
space:
mode:
authorjgart <jgart@dismail.de>2021-11-30 20:56:46 -0500
committerEfraim Flashner <efraim@flashner.co.il>2021-12-01 14:08:46 +0200
commit2eca48e3101cfa7a787732d471a0b77fac07af07 (patch)
tree23165dca6437933ee3e0ad5624133449fcc39bf9 /gnu/packages/julia-xyz.scm
parentce6ea46d409c0ef56f18c02a862ea48504392489 (diff)
downloadguix-patches-2eca48e3101cfa7a787732d471a0b77fac07af07.tar
guix-patches-2eca48e3101cfa7a787732d471a0b77fac07af07.tar.gz
gnu: Add julia-softglobalscope.
* gnu/packages/julay-xyz.scm (julia-softglobalscope): New variable. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages/julia-xyz.scm')
-rw-r--r--gnu/packages/julia-xyz.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index 547d2bf81e..ef9690262b 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -3,6 +3,7 @@
;;; Copyright © 2021 Simon Tournier <zimon.toutoune@gmail.com>
;;; Copyright © 2021 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2021 Vinicius Monego <monego@posteo.net>
+;;; Copyright © 2021 jgart <jgart@dismail.de>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -4191,6 +4192,29 @@ types can be added to a trait after the creation of the trait, whereas Union
types are fixed after creation.")
(license license:expat)))
+(define-public julia-softglobalscope
+ (package
+ (name "julia-softglobalscope")
+ (version "1.1.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/stevengj/SoftGlobalScope.jl")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1n3l0al1vw5jpb4k9a29a71666cdb617nmiqg34wcmyfzrxpvv39"))))
+ (build-system julia-build-system)
+ (home-page "https://github.com/stevengj/SoftGlobalScope.jl")
+ (synopsis "Utilities for soft global scope in interactive Julia environments")
+ (description
+ "SoftGlobalScope is a package for the Julia language that simplifies the
+variable scoping rules for code in global scope. It is intended for interactive
+shells to make it easier to work interactively with Julia, especially for
+beginners.")
+ (license license:expat)))
+
(define-public julia-sortingalgorithms
(package
(name "julia-sortingalgorithms")