summaryrefslogtreecommitdiff
path: root/gnu/packages/julia-xyz.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-06-08 17:21:32 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-06-08 17:57:26 +0300
commitb2ca58bec90735b1768428f4d84dec124f747cd2 (patch)
treece32baafcaafb57fda318a5c7fd8e6738fd7bdd0 /gnu/packages/julia-xyz.scm
parent7cb023cc0184072633ed1052eb28b5880e807fe5 (diff)
downloadguix-patches-b2ca58bec90735b1768428f4d84dec124f747cd2.tar
guix-patches-b2ca58bec90735b1768428f4d84dec124f747cd2.tar.gz
gnu: Add julia-ratios.
* gnu/packages/julia-xyz.scm (julia-ratios): New variable.
Diffstat (limited to 'gnu/packages/julia-xyz.scm')
-rw-r--r--gnu/packages/julia-xyz.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index 62c8f2aa15..db7ca3af88 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -2167,6 +2167,26 @@ array data structures where the columns of the arrays are generated (on the fly)
by Ranges.")
(license license:expat)))
+(define-public julia-ratios
+ (package
+ (name "julia-ratios")
+ (version "0.4.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/timholy/Ratios.jl")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1a4fd4jq4qjply29rkwg3m1clfndjsbckj1b1dab1bc35h2c6yxh"))))
+ (build-system julia-build-system)
+ (home-page "https://github.com/timholy/Ratios.jl")
+ (synopsis "Faster Rational-like types for Julia")
+ (description "This package provides types similar to Julia's @code{Rational}
+type, which make some sacrifices but have better computational performance.")
+ (license license:expat)))
+
(define-public julia-recipesbase
(package
(name "julia-recipesbase")