summaryrefslogtreecommitdiff
path: root/gnu/packages/julia-xyz.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-06-08 17:19:05 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-06-08 17:57:26 +0300
commit7cb023cc0184072633ed1052eb28b5880e807fe5 (patch)
tree7e94080b2cd4971848b4df6ec5d9b791e1e32cc7 /gnu/packages/julia-xyz.scm
parent1ba8c88fc184a5ccf62bfb2f14941db075d80b32 (diff)
downloadguix-patches-7cb023cc0184072633ed1052eb28b5880e807fe5.tar
guix-patches-7cb023cc0184072633ed1052eb28b5880e807fe5.tar.gz
gnu: Add julia-identityranges.
* gnu/packages/julia-xyz.scm (julia-identityranges): New variable.
Diffstat (limited to 'gnu/packages/julia-xyz.scm')
-rw-r--r--gnu/packages/julia-xyz.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index 16adf60f12..62c8f2aa15 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -1223,6 +1223,32 @@ library for parsing HTML.")
implementing both a client and a server.")
(license license:expat)))
+(define-public julia-identityranges
+ (package
+ (name "julia-identityranges")
+ (version "0.3.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/JuliaArrays/IdentityRanges.jl")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0jvl4xn8f8k70sn473li5q62wbiycl5qi25b5k456h3a0j1lbiml"))))
+ (build-system julia-build-system)
+ (propagated-inputs
+ `(("julia-offsetarrays" ,julia-offsetarrays)))
+ (home-page "https://github.com/JuliaArrays/IdentityRanges.jl")
+ (synopsis "Ranges that preserve indices of views")
+ (description "@code{IdentityRanges} are Julia-language a helper type for
+creating \"views\" of arrays. They are a custom type of AbstractUnitRange that
+makes it easy to preserve the indices of array views. The key property of an
+@code{IdentityRange r} is that @code{r[i] == i} (hence the name of the
+type/package), and that they support arbitrary start/stop indices (i.e., not
+just starting at 1).")
+ (license license:expat)))
+
(define-public julia-ifelse
(package
(name "julia-ifelse")