summaryrefslogtreecommitdiff
path: root/gnu/packages/julia-xyz.scm
diff options
context:
space:
mode:
authorzimoun <zimon.toutoune@gmail.com>2022-01-04 23:47:48 +0100
committerEfraim Flashner <efraim@flashner.co.il>2022-01-10 15:15:34 +0200
commit7e8f5176c40f933ad0ecdf4ff8434dc50c6a1a49 (patch)
treee740bfd5d9e0809a9d2743c3f4993e88c91c7563 /gnu/packages/julia-xyz.scm
parent9bd4c35aac3b38e1302ac0c614dcbc3cb4f4e674 (diff)
downloadguix-patches-7e8f5176c40f933ad0ecdf4ff8434dc50c6a1a49.tar
guix-patches-7e8f5176c40f933ad0ecdf4ff8434dc50c6a1a49.tar.gz
gnu: Add julia-scanbyte.
* gnu/packages/julia-xyz.scm (julia-scanbyte): New variable. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages/julia-xyz.scm')
-rw-r--r--gnu/packages/julia-xyz.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index 9e88987643..f1d91f1146 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -4357,6 +4357,29 @@ a loadable module.")
@code{libsass} library to compile scss and sass files to css.")
(license license:expat)))
+(define-public julia-scanbyte
+ (package
+ (name "julia-scanbyte")
+ (version "0.3")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jakobnissen/ScanByte.jl")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0dqqa3d7c87358144pji6ik8xlki2hj0hkvjs72j5aypfms8rwn3"))))
+ (build-system julia-build-system)
+ (propagated-inputs
+ (list julia-simd))
+ (home-page "https://github.com/jakobnissen/ScanByte.jl")
+ (synopsis "Find the first occurrence of set of bytes in a chunk of memory")
+ (description "This package finds the first occurrence of a byte or set of
+bytes in a chunk of memory. Think of it like a much faster version of
+@code{findfirst} that only iterates over bytes in memory.")
+ (license license:expat)))
+
(define-public julia-scratch
(package
(name "julia-scratch")