summaryrefslogtreecommitdiff
path: root/gnu/packages/julia-xyz.scm
diff options
context:
space:
mode:
authorzimoun <zimon.toutoune@gmail.com>2022-01-04 23:47:47 +0100
committerEfraim Flashner <efraim@flashner.co.il>2022-01-10 15:15:34 +0200
commit9bd4c35aac3b38e1302ac0c614dcbc3cb4f4e674 (patch)
tree36820a524e9f8fb25193bebe0c3c57307391f089 /gnu/packages/julia-xyz.scm
parent1305d9f3b1087bd826582699c11a5e7fd92db3b6 (diff)
downloadguix-patches-9bd4c35aac3b38e1302ac0c614dcbc3cb4f4e674.tar
guix-patches-9bd4c35aac3b38e1302ac0c614dcbc3cb4f4e674.tar.gz
gnu: Add julia-simd.
* gnu/packages/julia-xyz.scm (julia-simd): New variable. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages/julia-xyz.scm')
-rw-r--r--gnu/packages/julia-xyz.scm27
1 files changed, 26 insertions, 1 deletions
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index 2872addaa3..9e88987643 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -1,6 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2020, 2021 Nicolò Balzarotti <nicolo@nixo.xyz>
-;;; Copyright © 2021 Simon Tournier <zimon.toutoune@gmail.com>
+;;; Copyright © 2021, 2022 Simon Tournier <zimon.toutoune@gmail.com>
;;; Copyright © 2021 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2021 Vinicius Monego <monego@posteo.net>
;;; Copyright © 2021 jgart <jgart@dismail.de>
@@ -4406,6 +4406,31 @@ formatting an array of n things, e.g. numbers, dates, unitful values. It's used
in @code{Gadfly}, @code{Plots} and @code{Makie} to label axes and keys.")
(license license:expat)))
+(define-public julia-simd
+ (package
+ (name "julia-simd")
+ (version "3.3.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/eschnett/SIMD.jl")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1jiic2hcl9l6zh6jgqzbd3ik2girmgvni4bq65kdci5l12k9la68"))))
+ (build-system julia-build-system)
+ (home-page "https://github.com/eschnett/SIMD.jl")
+ (synopsis "Explicit SIMD vectorization")
+ (description "This package allows programmers to explicitly SIMD-vectorize
+their Julia code. By exposing SIMD vector types and corresponding operations,
+the programmer can explicitly vectorize their code. While this does not
+guarantee that the generated machine code is efficient, it relieves the
+compiler from determining whether it is legal to vectorize the code, deciding
+whether it is beneficial to do so, and rearranging the code to synthesize
+vector instructions.")
+ (license license:expat)))
+
(define-public julia-simpletraits
(package
(name "julia-simpletraits")