summaryrefslogtreecommitdiff
path: root/gnu/packages/julia-xyz.scm
diff options
context:
space:
mode:
authorzimoun <zimon.toutoune@gmail.com>2022-01-04 23:47:49 +0100
committerEfraim Flashner <efraim@flashner.co.il>2022-01-10 15:15:35 +0200
commit542db364f5b42563cf60773a57f427766343c9a5 (patch)
tree1aac123f1d45003a4b4577164ad06501df83aed8 /gnu/packages/julia-xyz.scm
parent7e8f5176c40f933ad0ecdf4ff8434dc50c6a1a49 (diff)
downloadguix-patches-542db364f5b42563cf60773a57f427766343c9a5.tar
guix-patches-542db364f5b42563cf60773a57f427766343c9a5.tar.gz
gnu: Add julia-automa.
* gnu/packages/julia-xyz.scm (julia-automa): New variable. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages/julia-xyz.scm')
-rw-r--r--gnu/packages/julia-xyz.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index f1d91f1146..ee1fe8aa93 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -211,6 +211,34 @@ appropriate BLAS or optimised Julia linear algebra routines. This supports a
much wider class of matrix types than Julia's in-built @code{StridedArray}.")
(license license:expat)))
+(define-public julia-automa
+ (package
+ (name "julia-automa")
+ (version "0.8.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/BioJulia/Automa.jl")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0hmwvk3qw54p7f63a2dnzlmvkynfs62x9n8x952bcmczp35csgq0"))))
+ (build-system julia-build-system)
+ (propagated-inputs
+ (list julia-scanbyte
+ julia-transcodingstreams))
+ (home-page "https://github.com/BioJulia/Automa.jl")
+ (synopsis "Validation, parsing, and tokenizing based on state machine compiler")
+ (description "This package compiles regular expressions into Julia code,
+which is then compiled into low-level machine code by the Julia compiler. The
+package is designed to generate very efficient code to scan large text data,
+which is often much faster than handcrafted code. @code{Automa.jl} can insert
+arbitrary Julia code that will be executed in state transitions. This makes
+it possible, for example, to extract substrings that match a part of a regular
+expression.")
+ (license license:expat)))
+
(define-public julia-axisalgorithms
(package
(name "julia-axisalgorithms")