summaryrefslogtreecommitdiff
path: root/gnu/packages/julia-xyz.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-06-08 17:22:53 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-06-08 17:57:26 +0300
commit20b79fed7658329c92912d79882ed36df5d57fd3 (patch)
treeec4f31246bfc2f360fc0672d0d368e70b7cc5f31 /gnu/packages/julia-xyz.scm
parentb2ca58bec90735b1768428f4d84dec124f747cd2 (diff)
downloadguix-patches-20b79fed7658329c92912d79882ed36df5d57fd3.tar
guix-patches-20b79fed7658329c92912d79882ed36df5d57fd3.tar.gz
gnu: Add julia-woodburymatrices.
* gnu/packages/julia-xyz.scm (julia-woodburymatrices): New variable.
Diffstat (limited to 'gnu/packages/julia-xyz.scm')
-rw-r--r--gnu/packages/julia-xyz.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index db7ca3af88..4c558012a7 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -2886,6 +2886,29 @@ useful in order to support @code{VersionNumber} comparisons applied to
allows for efficient string representation and transfer")
(license license:expat)))
+(define-public julia-woodburymatrices
+ (package
+ (name "julia-woodburymatrices")
+ (version "0.5.3")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/timholy/WoodburyMatrices.jl")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "04yykivi8zrbryxlmb0p5xa6lma8iq22r5s863117dnnqj5gaffd"))))
+ (build-system julia-build-system)
+ (home-page "https://github.com/timholy/WoodburyMatrices.jl")
+ (synopsis "Support for the Woodbury matrix identity for Julia")
+ (description "This package provides support for the Woodbury matrix identity
+for the Julia programming language. This is a generalization of the
+Sherman-Morrison formula. Note that the Woodbury matrix identity is notorious
+for floating-point roundoff errors, so be prepared for a certain amount of
+inaccuracy in the result.")
+ (license license:expat)))
+
(define-public julia-zipfile
(package
(name "julia-zipfile")