summaryrefslogtreecommitdiff
path: root/gnu/packages/julia-jll.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-05-30 12:40:10 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-05-30 12:55:56 +0300
commitdfaddea2f3e271bbc2f8c7ff85955fe716a87d1c (patch)
treece101b4e6971a7b53d3e77393472858526d19b81 /gnu/packages/julia-jll.scm
parent824f4bae6bbec359f795a9f22ccab2b96037b5ab (diff)
downloadguix-patches-dfaddea2f3e271bbc2f8c7ff85955fe716a87d1c.tar
guix-patches-dfaddea2f3e271bbc2f8c7ff85955fe716a87d1c.tar.gz
gnu: Add julia-wayland-protocols-jll.
* gnu/packages/julia-jll.scm (julia-wayland-protocols-jll): New variable.
Diffstat (limited to 'gnu/packages/julia-jll.scm')
-rw-r--r--gnu/packages/julia-jll.scm37
1 files changed, 37 insertions, 0 deletions
diff --git a/gnu/packages/julia-jll.scm b/gnu/packages/julia-jll.scm
index 7a2977e058..e06a281275 100644
--- a/gnu/packages/julia-jll.scm
+++ b/gnu/packages/julia-jll.scm
@@ -1520,6 +1520,43 @@ build tree Yggdrasil.")
(description "This package provides a wrapper for the wayland library.")
(license license:expat)))
+(define-public julia-wayland-protocols-jll
+ (package
+ (name "julia-wayland-protocols-jll")
+ (version "1.18.0+3")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/JuliaBinaryWrappers/Wayland_protocols_jll.jl")
+ (commit (string-append "Wayland_protocols-v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1dc9d2wzgybqjlg8l7f4ridkv2d66dg3lb3zihnl0k64psibn4x9"))))
+ (build-system julia-build-system)
+ (arguments
+ '(#:tests? #f ; no runtests
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'override-binary-path
+ (lambda* (#:key inputs #:allow-other-keys)
+ (map
+ (lambda (wrapper)
+ (substitute* wrapper
+ (("artifact\"Wayland_protocols\"")
+ (string-append "\"" (assoc-ref inputs "wayland-protocols") "\""))))
+ ;; There's a Julia file for each platform, override them all
+ (find-files "src/wrappers/" "\\.jl$")))))))
+ (inputs
+ `(("wayland-protocols" ,wayland-protocols)))
+ (propagated-inputs
+ `(("julia-jllwrappers" ,julia-jllwrappers)
+ ("julia-wayland-jll" ,julia-wayland-jll)))
+ (home-page "https://github.com/JuliaBinaryWrappers/Wayland_protocols_jll.jl")
+ (synopsis "Wayland-protocols library wrappers")
+ (description "This package provides a wrapper for the wayland-protocols library.")
+ (license license:expat)))
+
(define-public julia-x264-jll
(package
(name "julia-x264-jll")