summaryrefslogtreecommitdiff
path: root/gnu/packages/julia-jll.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-05-30 12:39:31 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-05-30 12:55:56 +0300
commit824f4bae6bbec359f795a9f22ccab2b96037b5ab (patch)
treef2cd4f9b02ffc5f34422bdb5c53ed831be06978f /gnu/packages/julia-jll.scm
parent46fafec9c68debce225035ac08aefaa793bfc0c9 (diff)
downloadguix-patches-824f4bae6bbec359f795a9f22ccab2b96037b5ab.tar
guix-patches-824f4bae6bbec359f795a9f22ccab2b96037b5ab.tar.gz
gnu: Add julia-wayland-jll.
* gnu/packages/julia-jll.scm (julia-wayland-jll): New variable.
Diffstat (limited to 'gnu/packages/julia-jll.scm')
-rw-r--r--gnu/packages/julia-jll.scm40
1 files changed, 40 insertions, 0 deletions
diff --git a/gnu/packages/julia-jll.scm b/gnu/packages/julia-jll.scm
index 500d7d0211..7a2977e058 100644
--- a/gnu/packages/julia-jll.scm
+++ b/gnu/packages/julia-jll.scm
@@ -29,6 +29,7 @@
#:use-module (gnu packages base)
#:use-module (gnu packages compression)
#:use-module (gnu packages fontutils)
+ #:use-module (gnu packages freedesktop)
#:use-module (gnu packages fribidi)
#:use-module (gnu packages gcc)
#:use-module (gnu packages gettext)
@@ -1480,6 +1481,45 @@ build tree Yggdrasil.")
(description "This package provides a wrapper for the pixman library.")
(license license:expat)))
+(define-public julia-wayland-jll
+ (package
+ (name "julia-wayland-jll")
+ (version "1.17.0+3")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/JuliaBinaryWrappers/Wayland_jll.jl")
+ (commit (string-append "Wayland-v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1w53inz62va3f022pgw3rfw5z5vgiv8z9dg3lfzpjrdb0lcd6ab6"))))
+ (build-system julia-build-system)
+ (arguments
+ '(#:tests? #f ; no runtests
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'override-binary-path
+ (lambda* (#:key inputs #:allow-other-keys)
+ (map
+ (lambda (wrapper)
+ (substitute* wrapper
+ (("artifact\"Wayland\"")
+ (string-append "\"" (assoc-ref inputs "wayland") "\""))))
+ ;; There's a Julia file for each platform, override them all
+ (find-files "src/wrappers/" "\\.jl$")))))))
+ (inputs
+ `(("wayland" ,wayland)))
+ (propagated-inputs
+ `(("julia-jllwrappers" ,julia-jllwrappers)
+ ("julia-expat-jll" ,julia-expat-jll)
+ ("julia-libffi-jll" ,julia-libffi-jll)
+ ("julia-xml2-jll" ,julia-xml2-jll)))
+ (home-page "https://github.com/JuliaBinaryWrappers/Wayland_jll.jl")
+ (synopsis "Wayland library wrappers")
+ (description "This package provides a wrapper for the wayland library.")
+ (license license:expat)))
+
(define-public julia-x264-jll
(package
(name "julia-x264-jll")