summaryrefslogtreecommitdiff
path: root/gnu/packages/julia-jll.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-05-30 12:41:03 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-05-30 12:55:56 +0300
commita2eb232b6ab7525af8d83964fd819b14b0a332ef (patch)
treeba005e2dbf049f763442abfeb7bd4b727e95ffb5 /gnu/packages/julia-jll.scm
parentdfaddea2f3e271bbc2f8c7ff85955fe716a87d1c (diff)
downloadguix-patches-a2eb232b6ab7525af8d83964fd819b14b0a332ef.tar
guix-patches-a2eb232b6ab7525af8d83964fd819b14b0a332ef.tar.gz
gnu: Add julia-xorg-libxkbfile-jll.
* gnu/packages/julia-jll.scm (julia-xorg-libxkbfile-jll): New variable.
Diffstat (limited to 'gnu/packages/julia-jll.scm')
-rw-r--r--gnu/packages/julia-jll.scm37
1 files changed, 37 insertions, 0 deletions
diff --git a/gnu/packages/julia-jll.scm b/gnu/packages/julia-jll.scm
index e06a281275..25a78e8074 100644
--- a/gnu/packages/julia-jll.scm
+++ b/gnu/packages/julia-jll.scm
@@ -2048,6 +2048,43 @@ build tree Yggdrasil.")
(description "This package provides a wrapper for the libxinerama library.")
(license license:expat)))
+(define-public julia-xorg-libxkbfile-jll
+ (package
+ (name "julia-xorg-libxkbfile-jll")
+ (version "1.1.0+3")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/JuliaBinaryWrappers/Xorg_libxkbfile_jll.jl")
+ (commit (string-append "Xorg_libxkbfile-v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0zrnrixz34h54n0c06ziaxcajvndydzgxxh5jbvqx1xrij5rw5gy"))))
+ (build-system julia-build-system)
+ (arguments
+ '(#:tests? #f ; no runtests
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'override-binary-path
+ (lambda* (#:key inputs #:allow-other-keys)
+ (map
+ (lambda (wrapper)
+ (substitute* wrapper
+ (("artifact\"Xorg_libxkbfile\"")
+ (string-append "\"" (assoc-ref inputs "libxkbfile") "\""))))
+ ;; There's a Julia file for each platform, override them all
+ (find-files "src/wrappers/" "\\.jl$")))))))
+ (inputs
+ `(("libxkbfile" ,libxkbfile)))
+ (propagated-inputs
+ `(("julia-jllwrappers" ,julia-jllwrappers)
+ ("julia-xorg-libx11-jll" ,julia-xorg-libx11-jll)))
+ (home-page "https://github.com/JuliaBinaryWrappers/Xorg_libxkbfile_jll.jl")
+ (synopsis "Libxkbfile library wrappers")
+ (description "This package provides a wrapper for the libxkbfile library.")
+ (license license:expat)))
+
(define-public julia-xorg-libxrandr-jll
(package
(name "julia-xorg-libxrandr-jll")