summaryrefslogtreecommitdiff
path: root/gnu/packages/julia-jll.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-05-30 12:21:56 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-05-30 12:55:53 +0300
commit8a2e54cb6f0a96de22ae7dc4897bbbb86ed3bb87 (patch)
tree343f19b2882ceaef2cf6f6a7686b2ce3aaa60f28 /gnu/packages/julia-jll.scm
parentf57a0f49925c53d6094722654ac29f4477517a89 (diff)
downloadguix-patches-8a2e54cb6f0a96de22ae7dc4897bbbb86ed3bb87.tar
guix-patches-8a2e54cb6f0a96de22ae7dc4897bbbb86ed3bb87.tar.gz
gnu: Add julia-xslt-jll.
* gnu/packages/julia-jll.scm (julia-xslt-jll): New variable.
Diffstat (limited to 'gnu/packages/julia-jll.scm')
-rw-r--r--gnu/packages/julia-jll.scm43
1 files changed, 43 insertions, 0 deletions
diff --git a/gnu/packages/julia-jll.scm b/gnu/packages/julia-jll.scm
index 8f26a49244..df9bf509ef 100644
--- a/gnu/packages/julia-jll.scm
+++ b/gnu/packages/julia-jll.scm
@@ -1533,6 +1533,49 @@ build tree Yggdrasil.")
(description "This package provides a wrapper for the xtrans library.")
(license license:expat)))
+(define-public julia-xslt-jll
+ (package
+ (name "julia-xslt-jll")
+ (version "1.1.34+0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/JuliaBinaryWrappers/XSLT_jll.jl")
+ (commit (string-append "XSLT-v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0wjkfnrgpd7c6i4ga5xzsqqmfrxcdkr1kjsxmd9bff8cqvyknnhq"))))
+ (build-system julia-build-system)
+ (arguments
+ '(#:tests? #f ; no runtests
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'override-binary-path
+ (lambda* (#:key inputs #:allow-other-keys)
+ (map
+ (lambda (wrapper)
+ (substitute* wrapper
+ (("generate_wrapper_header.*")
+ (string-append
+ "generate_wrapper_header(\"XSLT\", \""
+ (assoc-ref inputs "libxslt") "\")\n"))))
+ ;; There's a Julia file for each platform, override them all
+ (find-files "src/wrappers/" "\\.jl$")))))))
+ (inputs
+ `(("libxslt" ,libxslt)))
+ (propagated-inputs
+ `(("julia-jllwrappers" ,julia-jllwrappers)
+ ("julia-libgcrypt-jll" ,julia-libgcrypt-jll)
+ ("julia-libgpg-error-jll" ,julia-libgpg-error-jll)
+ ("julia-libiconv-jll" ,julia-libiconv-jll)
+ ("julia-xml2-jll" ,julia-xml2-jll)
+ ("julia-zlib-jll" ,julia-zlib-jll)))
+ (home-page "https://github.com/JuliaBinaryWrappers/XSLT_jll.jl")
+ (synopsis "Xslt library wrappers")
+ (description "This package provides a wrapper for the libxslt library.")
+ (license license:expat)))
+
(define-public julia-zlib-jll
(package
(name "julia-zlib-jll")