summaryrefslogtreecommitdiff
path: root/gnu/packages/julia-jll.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-05-30 12:17:10 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-05-30 12:55:53 +0300
commitf57a0f49925c53d6094722654ac29f4477517a89 (patch)
treecf8e24c32a8eb5d683aca0fd90ef14f3956f63cd /gnu/packages/julia-jll.scm
parent6e795958ebbf2edcb4e0838b36a34613f863a3b6 (diff)
downloadguix-patches-f57a0f49925c53d6094722654ac29f4477517a89.tar
guix-patches-f57a0f49925c53d6094722654ac29f4477517a89.tar.gz
gnu: Add julia-lzo-jll.
* gnu/packages/julia-jll.scm (julia-lzo-jll): New variable.
Diffstat (limited to 'gnu/packages/julia-jll.scm')
-rw-r--r--gnu/packages/julia-jll.scm38
1 files changed, 38 insertions, 0 deletions
diff --git a/gnu/packages/julia-jll.scm b/gnu/packages/julia-jll.scm
index cf54e14097..8f26a49244 100644
--- a/gnu/packages/julia-jll.scm
+++ b/gnu/packages/julia-jll.scm
@@ -1002,6 +1002,44 @@ from util-linux.")
"This package provides a wrapper for the libvorbis audio library.")
(license license:expat)))
+(define-public julia-lzo-jll
+ (package
+ (name "julia-lzo-jll")
+ (version "2.10.1+0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/JuliaBinaryWrappers/LZO_jll.jl")
+ (commit (string-append "LZO-v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1gy57znz3b6pk902vgdzlrwrxib0bcfl0zr1prinfbr9vfmiv1h0"))))
+ (build-system julia-build-system)
+ (arguments
+ '(#:tests? #f ; no runtests
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'override-binary-path
+ (lambda* (#:key inputs #:allow-other-keys)
+ (map
+ (lambda (wrapper)
+ (substitute* wrapper
+ (("generate_wrapper_header.*")
+ (string-append
+ "generate_wrapper_header(\"LZO\", \""
+ (assoc-ref inputs "lzo") "\")\n"))))
+ ;; There's a Julia file for each platform, override them all
+ (find-files "src/wrappers/" "\\.jl$")))))))
+ (inputs
+ `(("lzo" ,lzo)))
+ (propagated-inputs
+ `(("julia-jllwrappers" ,julia-jllwrappers)))
+ (home-page "https://github.com/JuliaBinaryWrappers/LZO_jll.jl")
+ (synopsis "LZO library wrappers")
+ (description "This package provides a wrapper for the lzo library.")
+ (license license:expat)))
+
(define-public julia-mbedtls-jll
(package
(name "julia-mbedtls-jll")