summaryrefslogtreecommitdiff
path: root/gnu/packages/julia-jll.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-05-30 12:11:17 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-05-30 12:55:53 +0300
commit71b0d280f7c1dcd6afa735314c970f44b465f6a4 (patch)
treef09a598a768ecfe581afdb4212c5ed08f461c842 /gnu/packages/julia-jll.scm
parent154f0a9b1439f2a18f6daf0b27a993da38c088e1 (diff)
downloadguix-patches-71b0d280f7c1dcd6afa735314c970f44b465f6a4.tar
guix-patches-71b0d280f7c1dcd6afa735314c970f44b465f6a4.tar.gz
gnu: Add julia-xorg-libxdmcp-jll.
* gnu/packages/julia-jll.scm (julia-xorg-libxdmcp-jll): New variable.
Diffstat (limited to 'gnu/packages/julia-jll.scm')
-rw-r--r--gnu/packages/julia-jll.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/julia-jll.scm b/gnu/packages/julia-jll.scm
index e528c42342..6d8230b85b 100644
--- a/gnu/packages/julia-jll.scm
+++ b/gnu/packages/julia-jll.scm
@@ -1345,6 +1345,42 @@ build tree Yggdrasil.")
(description "This package provides a wrapper for the libxau library.")
(license license:expat)))
+(define-public julia-xorg-libxdmcp-jll
+ (package
+ (name "julia-xorg-libxdmcp-jll")
+ (version "1.1.3+3")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/JuliaBinaryWrappers/Xorg_libXdmcp_jll.jl")
+ (commit (string-append "Xorg_libXdmcp-v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1ghw8c7ibkm2hv4h38qyhbxfmyizxszqv6fv8qzlb5031dmshnap"))))
+ (build-system julia-build-system)
+ (arguments
+ '(#:tests? #f ; no runtests
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'override-binary-path
+ (lambda* (#:key inputs #:allow-other-keys)
+ (map
+ (lambda (wrapper)
+ (substitute* wrapper
+ (("artifact\"Xorg_libXdmcp\"")
+ (string-append "\"" (assoc-ref inputs "libxdmcp") "\""))))
+ ;; There's a Julia file for each platform, override them all
+ (find-files "src/wrappers/" "\\.jl$")))))))
+ (inputs
+ `(("libxdmcp" ,libxdmcp)))
+ (propagated-inputs
+ `(("julia-jllwrappers" ,julia-jllwrappers)))
+ (home-page "https://github.com/JuliaBinaryWrappers/Xorg_libXdmcp_jll.jl")
+ (synopsis "Libxdmcp library wrappers")
+ (description "This package provides a wrapper for the libxdmcp library.")
+ (license license:expat)))
+
(define-public julia-zlib-jll
(package
(name "julia-zlib-jll")