summaryrefslogtreecommitdiff
path: root/gnu/packages/julia-jll.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-05-30 12:10:26 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-05-30 12:55:53 +0300
commit154f0a9b1439f2a18f6daf0b27a993da38c088e1 (patch)
tree75da308b17f3e6d10e8347fb28629d08150c673d /gnu/packages/julia-jll.scm
parent3d12f59d1f8437f17914d2ae0cb6b46f3b2dedae (diff)
downloadguix-patches-154f0a9b1439f2a18f6daf0b27a993da38c088e1.tar
guix-patches-154f0a9b1439f2a18f6daf0b27a993da38c088e1.tar.gz
gnu: Add julia-xorg-libxau-jll.
* gnu/packages/julia-jll.scm (julia-xorg-libxau-jll): New variable.
Diffstat (limited to 'gnu/packages/julia-jll.scm')
-rw-r--r--gnu/packages/julia-jll.scm39
1 files changed, 38 insertions, 1 deletions
diff --git a/gnu/packages/julia-jll.scm b/gnu/packages/julia-jll.scm
index c10d371769..e528c42342 100644
--- a/gnu/packages/julia-jll.scm
+++ b/gnu/packages/julia-jll.scm
@@ -46,7 +46,8 @@
#:use-module (gnu packages web)
#:use-module (gnu packages xdisorg)
#:use-module (gnu packages xiph)
- #:use-module (gnu packages xml))
+ #:use-module (gnu packages xml)
+ #:use-module (gnu packages xorg))
;;; TODO: Remove this autogenerated source package
;;; and build it from realse source using <https://github.com/JuliaPackaging/Yggdrasil/>
@@ -1308,6 +1309,42 @@ build tree Yggdrasil.")
(description "This package provides a wrapper for the libxml2 library.")
(license license:expat)))
+(define-public julia-xorg-libxau-jll
+ (package
+ (name "julia-xorg-libxau-jll")
+ (version "1.0.9+3")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/JuliaBinaryWrappers/Xorg_libXau_jll.jl")
+ (commit (string-append "Xorg_libXau-v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1bc59hzg4jgdy0lwykp6avxsb87fq9j79c30yxprwjvxq8xm3p8z"))))
+ (build-system julia-build-system)
+ (arguments
+ '(#:tests? #f ; no runtests
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'override-binary-path
+ (lambda* (#:key inputs #:allow-other-keys)
+ (map
+ (lambda (wrapper)
+ (substitute* wrapper
+ (("artifact\"Xorg_libXau\"")
+ (string-append "\"" (assoc-ref inputs "libxau") "\""))))
+ ;; There's a Julia file for each platform, override them all
+ (find-files "src/wrappers/" "\\.jl$")))))))
+ (inputs
+ `(("libxau" ,libxau)))
+ (propagated-inputs
+ `(("julia-jllwrappers" ,julia-jllwrappers)))
+ (home-page "https://github.com/JuliaBinaryWrappers/Xorg_libXau_jll.jl")
+ (synopsis "Libxau library wrappers")
+ (description "This package provides a wrapper for the libxau library.")
+ (license license:expat)))
+
(define-public julia-zlib-jll
(package
(name "julia-zlib-jll")