summaryrefslogtreecommitdiff
path: root/gnu/packages/julia-jll.scm
diff options
context:
space:
mode:
authorJean-Baptiste Volatier <jbv@pm.me>2021-11-12 14:23:52 +0000
committerEfraim Flashner <efraim@flashner.co.il>2021-11-16 14:39:51 +0200
commit3af351a7de41b8d50f27f3623c46392f571b9a4e (patch)
tree4bb6d5d021633c1c0c5883ab7c6ac0c7b8da17f1 /gnu/packages/julia-jll.scm
parente31d48d8db09e723727eeadbeea22d677f5d1d52 (diff)
downloadguix-patches-3af351a7de41b8d50f27f3623c46392f571b9a4e.tar
guix-patches-3af351a7de41b8d50f27f3623c46392f571b9a4e.tar.gz
build-system/julia: Enable Julia Pkg to find installed packages.
Julia's built-in package manager (Pkg) looks for packages in JULIA_DEPOT_PATH/packages/PACKAGENAME/XXXX, where XXXX is a string encoding package UUID and SHA1 of files. The link-depot phase creates a link at the correct location to allow Pkg to find packages that were already installed by Guix. * guix/build/julia-build-system.scm (link-depot): New phase. (%package-path): Modified package path from packages/ to loadpath/. (project.toml->uuid): New procedure, retrive package uuid from TOML file. (precompile, check): Adjust to the change in paths. (%standard-phases): Add link-depot phase. (julia-build): Add julia-package-uuid keyword. * guix/build-system/julia.scm (julia-build): Also use the julia-package-uuid keyword. * gnu/packages/julia-jll.scm (julia-bzip2-jll, julia-cairo-jll, julia-compilersupportlibraries-jll, julia-expat-jll, julia-ffmpeg-jll, julia-fontconfig-jll, julia-freetype2-jll, julia-fribidi-jll, julia-gettext-jll, julia-glib-jll, julia-gr-jll, julia-gumbo-jll, julia-imagemagick-jll, julia-jllwrappers-jll, julia-jpegturbo-jll, julia-lame-jll, julia-libass-jll, julia-libfdk-aac-jll, julia-libffi-jll, julia-libgcrypt-jll, julia-libglvnd-jll, julia-libgpg-error-jll, juli-libiconv-jll, julia-libmount-jll, julia-libpng-jll, julia-libsass-jll, julia-libtiff-jll, julia-libuuid-jll, julia-libvorbis-jll, julia-lzo-jll, julia-mbedtls-jll, julia-ogg-jll, julia-openspecfun-jll, julia-openssl-jll, julia-opus-jll, julia-pcre-jll, julia-pixman-jll, julia-qt5base-jll, julia-wayland-jll, julia-wayland-protocols-jll, julia-x264-jll, julia-x265-jll, julia-xkbcommon-jll, julia-xml2-jll, julia-xorg-libpthread-stubs-jll, julia-xorg-libx11-jll, julia-xorg-libxau-jll, julia-xorg-libxcb-jll, julia-xorg-libxcursor-jll, julia-xorg-libxdmcp-jll, julia-xorg-libxext-jll, julia-xorg-libxfixes-jll, julia-xorg-libxi-jll, julia-xorg-libxinerama-jll, julia-xorg-libxkbfile-jll, julia-xorg-libxrandr-jll, julia-xorg-libxrender-jll, julia-xorg-xcb-util-jll, julia-xorg-xcb-util-keysyms-jll, julia-xorg-xcb-util-renderutil-jll, julia-xorg-xcb-util-wm-jll, julia-xorg-xkbcomp-jll, julia-xorg-xkeyboard-config-jll, julia-xorg-xtrans-jll, julia-xslt-jll, julia-zlib-jll, julia-zstd-jll) [argument]: Adjust the order of the phases to the change in the julia-build-system. * gnu/packages/julia-xyz.scm (julia-bufferedstreams, julia-calculus, julia-dataframes, julia-datavalues, julia-distances, julia-documenter, julia-dualnumbers, julia-ellipsisnotation, julia-expronicon, julia-fileio, julia-fixedpointnumbers, julia-functionwrappers, julia-fuzzycompletions, julia-genericlinearalgebra, julia-genericschur, julia-geometrybasics, julia-imagemagick, julia-infinity, julia-matrixfactorizations, julia-media, julia-missings, julia-nnlib, julia-optimtestproblems, julia-orderedcollections, julia-prettytables, julia-pycall, julia-quadmath, julia-safetests, julia-stackviews) [arguments]: Correct paths to reflect change of %package-path modify order of phases as link-depot needs to run on an unmodified src directory add package-name-uuid keyword argument to packages without Project.toml file. * gnu/packages/julia.scm (julia)[native-search-paths]: Correct paths to reflect change of %package-path modify order of phases as link-depot needs to run on an unmodified src directory. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages/julia-jll.scm')
-rw-r--r--gnu/packages/julia-jll.scm138
1 files changed, 69 insertions, 69 deletions
diff --git a/gnu/packages/julia-jll.scm b/gnu/packages/julia-jll.scm
index 51643819ae..d8cf5b9eaf 100644
--- a/gnu/packages/julia-jll.scm
+++ b/gnu/packages/julia-jll.scm
@@ -77,7 +77,7 @@
'(#:tests? #f ; No runtests.jl
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'override-binary-path
+ (add-after 'link-depot 'override-binary-path
(lambda* (#:key inputs #:allow-other-keys)
(map
(lambda (wrapper)
@@ -117,7 +117,7 @@ compression program.")
'(#:tests? #f ; no runtests
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'override-binary-path
+ (add-after 'link-depot 'override-binary-path
(lambda* (#:key inputs #:allow-other-keys)
(map
(lambda (wrapper)
@@ -163,7 +163,7 @@ compression program.")
`(#:tests? #f ; no runtests.jl
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'override-binary-path
+ (add-after 'link-depot 'override-binary-path
(lambda* (#:key inputs #:allow-other-keys)
(map
(lambda (wrapper)
@@ -205,7 +205,7 @@ build tree Yggdrasil.")
'(#:tests? #f ; no runtests
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'override-binary-path
+ (add-after 'link-depot 'override-binary-path
(lambda* (#:key inputs #:allow-other-keys)
(map
(lambda (wrapper)
@@ -243,7 +243,7 @@ build tree Yggdrasil.")
'(#:tests? #f ; no runtests
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'override-binary-path
+ (add-after 'link-depot 'override-binary-path
(lambda* (#:key inputs #:allow-other-keys)
(map
(lambda (wrapper)
@@ -292,7 +292,7 @@ build tree Yggdrasil.")
'(#:tests? #f ; no runtests
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'override-binary-path
+ (add-after 'link-depot 'override-binary-path
(lambda* (#:key inputs #:allow-other-keys)
(map
(lambda (wrapper)
@@ -335,7 +335,7 @@ build tree Yggdrasil.")
'(#:tests? #f ; No runtests.jl
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'override-binary-path
+ (add-after 'link-depot 'override-binary-path
(lambda* (#:key inputs #:allow-other-keys)
(map
(lambda (wrapper)
@@ -377,7 +377,7 @@ rendering library.")
'(#:tests? #f ; no runtests
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'override-binary-path
+ (add-after 'link-depot 'override-binary-path
(lambda* (#:key inputs #:allow-other-keys)
(map
(lambda (wrapper)
@@ -413,7 +413,7 @@ rendering library.")
'(#:tests? #f ; no runtests
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'override-binary-path
+ (add-after 'link-depot 'override-binary-path
(lambda* (#:key inputs #:allow-other-keys)
(map
(lambda (wrapper)
@@ -454,7 +454,7 @@ rendering library.")
'(#:tests? #f ; no runtests
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'override-binary-path
+ (add-after 'link-depot 'override-binary-path
(lambda* (#:key inputs #:allow-other-keys)
(map
(lambda (wrapper)
@@ -497,7 +497,7 @@ rendering library.")
'(#:tests? #f ; no runtests
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'override-binary-path
+ (add-after 'link-depot 'override-binary-path
(lambda* (#:key inputs #:allow-other-keys)
(map
(lambda (wrapper)
@@ -541,7 +541,7 @@ rendering library.")
'(#:tests? #f ; no runtests
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'override-binary-path
+ (add-after 'link-depot 'override-binary-path
(lambda* (#:key inputs #:allow-other-keys)
(map
(lambda (wrapper)
@@ -590,7 +590,7 @@ rendering library.")
'(#:tests? #f ; no runtests
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'override-binary-path
+ (add-after 'link-depot 'override-binary-path
(lambda* (#:key inputs #:allow-other-keys)
(let ((gumbo (string-append (assoc-ref inputs "gumbo-parser"))))
(for-each
@@ -630,7 +630,7 @@ rendering library.")
'(#:tests? #f ; no runtests
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'override-binary-path
+ (add-after 'link-depot 'override-binary-path
(lambda* (#:key inputs #:allow-other-keys)
(map
(lambda (wrapper)
@@ -672,7 +672,7 @@ rendering library.")
'(#:tests? #f
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'custom-override-path
+ (add-after 'link-depot 'custom-override-path
(lambda* (#:key inputs #:allow-other-keys)
;; Make @generate_wrapper_header take an optional argument that
;; guix packagers can pass to override the default "override"
@@ -718,7 +718,7 @@ used in autogenerated packages via @code{BinaryBuilder.jl}.")
'(#:tests? #f ; no runtests
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'override-binary-path
+ (add-after 'link-depot 'override-binary-path
(lambda* (#:key inputs #:allow-other-keys)
(map
(lambda (wrapper)
@@ -754,7 +754,7 @@ used in autogenerated packages via @code{BinaryBuilder.jl}.")
'(#:tests? #f ; no runtests
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'override-binary-path
+ (add-after 'link-depot 'override-binary-path
(lambda* (#:key inputs #:allow-other-keys)
(map
(lambda (wrapper)
@@ -790,7 +790,7 @@ used in autogenerated packages via @code{BinaryBuilder.jl}.")
'(#:tests? #f ; no runtests
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'override-binary-path
+ (add-after 'link-depot 'override-binary-path
(lambda* (#:key inputs #:allow-other-keys)
(map
(lambda (wrapper)
@@ -830,7 +830,7 @@ used in autogenerated packages via @code{BinaryBuilder.jl}.")
'(#:tests? #f ; no runtests
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'override-binary-path
+ (add-after 'link-depot 'override-binary-path
(lambda* (#:key inputs #:allow-other-keys)
(map
(lambda (wrapper)
@@ -866,7 +866,7 @@ used in autogenerated packages via @code{BinaryBuilder.jl}.")
'(#:tests? #f ; no runtests
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'override-binary-path
+ (add-after 'link-depot 'override-binary-path
(lambda* (#:key inputs #:allow-other-keys)
(map
(lambda (wrapper)
@@ -903,7 +903,7 @@ used in autogenerated packages via @code{BinaryBuilder.jl}.")
'(#:tests? #f ; no runtests
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'override-binary-path
+ (add-after 'link-depot 'override-binary-path
(lambda* (#:key inputs #:allow-other-keys)
(map
(lambda (wrapper)
@@ -942,7 +942,7 @@ used in autogenerated packages via @code{BinaryBuilder.jl}.")
'(#:tests? #f ; no runtests
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'override-binary-path
+ (add-after 'link-depot 'override-binary-path
(lambda* (#:key inputs #:allow-other-keys)
(map
(lambda (wrapper)
@@ -980,7 +980,7 @@ used in autogenerated packages via @code{BinaryBuilder.jl}.")
'(#:tests? #f ; no runtests
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'override-binary-path
+ (add-after 'link-depot 'override-binary-path
(lambda* (#:key inputs #:allow-other-keys)
(map
(lambda (wrapper)
@@ -1018,7 +1018,7 @@ used in autogenerated packages via @code{BinaryBuilder.jl}.")
'(#:tests? #f ; no runtests
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'override-binary-path
+ (add-after 'link-depot 'override-binary-path
(lambda* (#:key inputs #:allow-other-keys)
(map
(lambda (wrapper)
@@ -1056,7 +1056,7 @@ used in autogenerated packages via @code{BinaryBuilder.jl}.")
'(#:tests? #f ; no runtests
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'override-binary-path
+ (add-after 'link-depot 'override-binary-path
(lambda* (#:key inputs #:allow-other-keys)
(map
(lambda (wrapper)
@@ -1095,7 +1095,7 @@ from util-linux.")
'(#:tests? #f ; no runtests
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'override-binary-path
+ (add-after 'link-depot 'override-binary-path
(lambda* (#:key inputs #:allow-other-keys)
(map
(lambda (wrapper)
@@ -1133,7 +1133,7 @@ from util-linux.")
`(#:tests? #f ; no runtests.jl
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'override-binary-path
+ (add-after 'link-depot 'override-binary-path
(lambda* (#:key inputs #:allow-other-keys)
(map
(lambda (wrapper)
@@ -1175,7 +1175,7 @@ build tree Yggdrasil.")
'(#:tests? #f ; no runtests
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'override-binary-path
+ (add-after 'link-depot 'override-binary-path
(lambda* (#:key inputs #:allow-other-keys)
(map
(lambda (wrapper)
@@ -1214,7 +1214,7 @@ build tree Yggdrasil.")
'(#:tests? #f ; no runtests
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'override-binary-path
+ (add-after 'link-depot 'override-binary-path
(lambda* (#:key inputs #:allow-other-keys)
(map
(lambda (wrapper)
@@ -1252,7 +1252,7 @@ build tree Yggdrasil.")
'(#:tests? #f ; no runtests
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'override-binary-path
+ (add-after 'link-depot 'override-binary-path
(lambda* (#:key inputs #:allow-other-keys)
(map
(lambda (wrapper)
@@ -1290,7 +1290,7 @@ build tree Yggdrasil.")
'(#:tests? #f ; no runtests
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'override-binary-path
+ (add-after 'link-depot 'override-binary-path
(lambda* (#:key inputs #:allow-other-keys)
(map
(lambda (wrapper)
@@ -1328,7 +1328,7 @@ build tree Yggdrasil.")
'(#:tests? #f ; No runtests.jl
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'override-binary-path
+ (add-after 'link-depot 'override-binary-path
(lambda* (#:key inputs #:allow-other-keys)
(map
(lambda (wrapper)
@@ -1366,7 +1366,7 @@ wrappers.")
'(#:tests? #f ; no runtests
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'override-binary-path
+ (add-after 'link-depot 'override-binary-path
(lambda* (#:key inputs #:allow-other-keys)
(map
(lambda (wrapper)
@@ -1403,7 +1403,7 @@ wrappers.")
`(#:tests? #f ; no runtests.jl
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'override-binary-path
+ (add-after 'link-depot 'override-binary-path
(lambda* (#:key inputs #:allow-other-keys)
(map
(lambda (wrapper)
@@ -1446,7 +1446,7 @@ build tree Yggdrasil.")
'(#:tests? #f ; no runtests
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'override-binary-path
+ (add-after 'link-depot 'override-binary-path
(lambda* (#:key inputs #:allow-other-keys)
(map
(lambda (wrapper)
@@ -1482,7 +1482,7 @@ build tree Yggdrasil.")
'(#:tests? #f ; no runtests
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'override-binary-path
+ (add-after 'link-depot 'override-binary-path
(lambda* (#:key inputs #:allow-other-keys)
(map
(lambda (wrapper)
@@ -1518,7 +1518,7 @@ build tree Yggdrasil.")
'(#:tests? #f ; no runtests
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'override-binary-path
+ (add-after 'link-depot 'override-binary-path
(lambda* (#:key inputs #:allow-other-keys)
(map
(lambda (wrapper)
@@ -1556,7 +1556,7 @@ build tree Yggdrasil.")
'(#:tests? #f ; no runtests
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'override-binary-path
+ (add-after 'link-depot 'override-binary-path
(lambda* (#:key inputs #:allow-other-keys)
(map
(lambda (wrapper)
@@ -1594,7 +1594,7 @@ build tree Yggdrasil.")
'(#:tests? #f ; no runtests
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'override-binary-path
+ (add-after 'link-depot 'override-binary-path
(lambda* (#:key inputs #:allow-other-keys)
(map
(lambda (wrapper)
@@ -1645,7 +1645,7 @@ build tree Yggdrasil.")
'(#:tests? #f ; no runtests
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'override-binary-path
+ (add-after 'link-depot 'override-binary-path
(lambda* (#:key inputs #:allow-other-keys)
(map
(lambda (wrapper)
@@ -1684,7 +1684,7 @@ build tree Yggdrasil.")
'(#:tests? #f ; no runtests
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'override-binary-path
+ (add-after 'link-depot 'override-binary-path
(lambda* (#:key inputs #:allow-other-keys)
(map
(lambda (wrapper)
@@ -1721,7 +1721,7 @@ build tree Yggdrasil.")
`(#:tests? #f ; no runtests
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'override-binary-path
+ (add-after 'link-depot 'override-binary-path
(lambda* (#:key inputs #:allow-other-keys)
(let ((libx264 (assoc-ref inputs "libx264")))
(map
@@ -1762,7 +1762,7 @@ build tree Yggdrasil.")
'(#:tests? #f ; no runtests
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'override-binary-path
+ (add-after 'link-depot 'override-binary-path
(lambda* (#:key inputs #:allow-other-keys)
(map
(lambda (wrapper)
@@ -1798,7 +1798,7 @@ build tree Yggdrasil.")
'(#:tests? #f ; no runtests
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'override-binary-path
+ (add-after 'link-depot 'override-binary-path
(lambda* (#:key inputs #:allow-other-keys)
(map
(lambda (wrapper)
@@ -1838,7 +1838,7 @@ build tree Yggdrasil.")
'(#:tests? #f ; no runtests
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'override-binary-path
+ (add-after 'link-depot 'override-binary-path
(lambda* (#:key inputs #:allow-other-keys)
(map
(lambda (wrapper)
@@ -1878,7 +1878,7 @@ build tree Yggdrasil.")
'(#:tests? #f ; no runtests
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'override-binary-path
+ (add-after 'link-depot 'override-binary-path
(lambda* (#:key inputs #:allow-other-keys)
(map
(lambda (wrapper)
@@ -1915,7 +1915,7 @@ build tree Yggdrasil.")
'(#:tests? #f ; no runtests
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'override-binary-path
+ (add-after 'link-depot 'override-binary-path
(lambda* (#:key inputs #:allow-other-keys)
(map
(lambda (wrapper)
@@ -1953,7 +1953,7 @@ build tree Yggdrasil.")
'(#:tests? #f ; no runtests
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'override-binary-path
+ (add-after 'link-depot 'override-binary-path
(lambda* (#:key inputs #:allow-other-keys)
(map
(lambda (wrapper)
@@ -1989,7 +1989,7 @@ build tree Yggdrasil.")
'(#:tests? #f ; no runtests
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'override-binary-path
+ (add-after 'link-depot 'override-binary-path
(lambda* (#:key inputs #:allow-other-keys)
(map
(lambda (wrapper)
@@ -2029,7 +2029,7 @@ build tree Yggdrasil.")
'(#:tests? #f ; no runtests
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'override-binary-path
+ (add-after 'link-depot 'override-binary-path
(lambda* (#:key inputs #:allow-other-keys)
(map
(lambda (wrapper)
@@ -2067,7 +2067,7 @@ build tree Yggdrasil.")
'(#:tests? #f ; no runtests
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'override-binary-path
+ (add-after 'link-depot 'override-binary-path
(lambda* (#:key inputs #:allow-other-keys)
(map
(lambda (wrapper)
@@ -2103,7 +2103,7 @@ build tree Yggdrasil.")
'(#:tests? #f ; no runtests
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'override-binary-path
+ (add-after 'link-depot 'override-binary-path
(lambda* (#:key inputs #:allow-other-keys)
(map
(lambda (wrapper)
@@ -2140,7 +2140,7 @@ build tree Yggdrasil.")
'(#:tests? #f ; no runtests
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'override-binary-path
+ (add-after 'link-depot 'override-binary-path
(lambda* (#:key inputs #:allow-other-keys)
(map
(lambda (wrapper)
@@ -2177,7 +2177,7 @@ build tree Yggdrasil.")
'(#:tests? #f ; no runtests
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'override-binary-path
+ (add-after 'link-depot 'override-binary-path
(lambda* (#:key inputs #:allow-other-keys)
(map
(lambda (wrapper)
@@ -2215,7 +2215,7 @@ build tree Yggdrasil.")
'(#:tests? #f ; no runtests
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'override-binary-path
+ (add-after 'link-depot 'override-binary-path
(lambda* (#:key inputs #:allow-other-keys)
(map
(lambda (wrapper)
@@ -2252,7 +2252,7 @@ build tree Yggdrasil.")
'(#:tests? #f ; no runtests
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'override-binary-path
+ (add-after 'link-depot 'override-binary-path
(lambda* (#:key inputs #:allow-other-keys)
(map
(lambda (wrapper)
@@ -2289,7 +2289,7 @@ build tree Yggdrasil.")
'(#:tests? #f ; no runtests
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'override-binary-path
+ (add-after 'link-depot 'override-binary-path
(lambda* (#:key inputs #:allow-other-keys)
(map
(lambda (wrapper)
@@ -2327,7 +2327,7 @@ build tree Yggdrasil.")
'(#:tests? #f ; no runtests
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'override-binary-path
+ (add-after 'link-depot 'override-binary-path
(lambda* (#:key inputs #:allow-other-keys)
(map
(lambda (wrapper)
@@ -2364,7 +2364,7 @@ build tree Yggdrasil.")
'(#:tests? #f ; no runtests
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'override-binary-path
+ (add-after 'link-depot 'override-binary-path
(lambda* (#:key inputs #:allow-other-keys)
(map
(lambda (wrapper)
@@ -2401,7 +2401,7 @@ build tree Yggdrasil.")
'(#:tests? #f ; no runtests
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'override-binary-path
+ (add-after 'link-depot 'override-binary-path
(lambda* (#:key inputs #:allow-other-keys)
(map
(lambda (wrapper)
@@ -2438,7 +2438,7 @@ build tree Yggdrasil.")
'(#:tests? #f ; no runtests
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'override-binary-path
+ (add-after 'link-depot 'override-binary-path
(lambda* (#:key inputs #:allow-other-keys)
(map
(lambda (wrapper)
@@ -2475,7 +2475,7 @@ build tree Yggdrasil.")
'(#:tests? #f ; no runtests
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'override-binary-path
+ (add-after 'link-depot 'override-binary-path
(lambda* (#:key inputs #:allow-other-keys)
(map
(lambda (wrapper)
@@ -2512,7 +2512,7 @@ build tree Yggdrasil.")
'(#:tests? #f ; no runtests
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'override-binary-path
+ (add-after 'link-depot 'override-binary-path
(lambda* (#:key inputs #:allow-other-keys)
(map
(lambda (wrapper)
@@ -2549,7 +2549,7 @@ build tree Yggdrasil.")
'(#:tests? #f ; no runtests
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'override-binary-path
+ (add-after 'link-depot 'override-binary-path
(lambda* (#:key inputs #:allow-other-keys)
(map
(lambda (wrapper)
@@ -2586,7 +2586,7 @@ build tree Yggdrasil.")
'(#:tests? #f ; no runtests
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'override-binary-path
+ (add-after 'link-depot 'override-binary-path
(lambda* (#:key inputs #:allow-other-keys)
(map
(lambda (wrapper)
@@ -2623,7 +2623,7 @@ build tree Yggdrasil.")
'(#:tests? #f ; no runtests
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'override-binary-path
+ (add-after 'link-depot 'override-binary-path
(lambda* (#:key inputs #:allow-other-keys)
(map
(lambda (wrapper)
@@ -2659,7 +2659,7 @@ build tree Yggdrasil.")
'(#:tests? #f ; no runtests
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'override-binary-path
+ (add-after 'link-depot 'override-binary-path
(lambda* (#:key inputs #:allow-other-keys)
(map
(lambda (wrapper)
@@ -2702,7 +2702,7 @@ build tree Yggdrasil.")
'(#:tests? #f ; no runtests
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'override-binary-path
+ (add-after 'link-depot 'override-binary-path
(lambda* (#:key inputs #:allow-other-keys)
(map
(lambda (wrapper)
@@ -2740,7 +2740,7 @@ build tree Yggdrasil.")
'(#:tests? #f ; no runtests
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'override-binary-path
+ (add-after 'link-depot 'override-binary-path
(lambda* (#:key inputs #:allow-other-keys)
(map
(lambda (wrapper)