summaryrefslogtreecommitdiff
path: root/gnu/packages
diff options
context:
space:
mode:
authorJean-Baptiste Volatier <jbv@pm.me>2021-11-12 14:23:52 +0000
committerEfraim Flashner <efraim@flashner.co.il>2021-11-16 14:39:51 +0200
commit3af351a7de41b8d50f27f3623c46392f571b9a4e (patch)
tree4bb6d5d021633c1c0c5883ab7c6ac0c7b8da17f1 /gnu/packages
parente31d48d8db09e723727eeadbeea22d677f5d1d52 (diff)
downloadguix-patches-3af351a7de41b8d50f27f3623c46392f571b9a4e.tar
guix-patches-3af351a7de41b8d50f27f3623c46392f571b9a4e.tar.gz
build-system/julia: Enable Julia Pkg to find installed packages.
Julia's built-in package manager (Pkg) looks for packages in JULIA_DEPOT_PATH/packages/PACKAGENAME/XXXX, where XXXX is a string encoding package UUID and SHA1 of files. The link-depot phase creates a link at the correct location to allow Pkg to find packages that were already installed by Guix. * guix/build/julia-build-system.scm (link-depot): New phase. (%package-path): Modified package path from packages/ to loadpath/. (project.toml->uuid): New procedure, retrive package uuid from TOML file. (precompile, check): Adjust to the change in paths. (%standard-phases): Add link-depot phase. (julia-build): Add julia-package-uuid keyword. * guix/build-system/julia.scm (julia-build): Also use the julia-package-uuid keyword. * gnu/packages/julia-jll.scm (julia-bzip2-jll, julia-cairo-jll, julia-compilersupportlibraries-jll, julia-expat-jll, julia-ffmpeg-jll, julia-fontconfig-jll, julia-freetype2-jll, julia-fribidi-jll, julia-gettext-jll, julia-glib-jll, julia-gr-jll, julia-gumbo-jll, julia-imagemagick-jll, julia-jllwrappers-jll, julia-jpegturbo-jll, julia-lame-jll, julia-libass-jll, julia-libfdk-aac-jll, julia-libffi-jll, julia-libgcrypt-jll, julia-libglvnd-jll, julia-libgpg-error-jll, juli-libiconv-jll, julia-libmount-jll, julia-libpng-jll, julia-libsass-jll, julia-libtiff-jll, julia-libuuid-jll, julia-libvorbis-jll, julia-lzo-jll, julia-mbedtls-jll, julia-ogg-jll, julia-openspecfun-jll, julia-openssl-jll, julia-opus-jll, julia-pcre-jll, julia-pixman-jll, julia-qt5base-jll, julia-wayland-jll, julia-wayland-protocols-jll, julia-x264-jll, julia-x265-jll, julia-xkbcommon-jll, julia-xml2-jll, julia-xorg-libpthread-stubs-jll, julia-xorg-libx11-jll, julia-xorg-libxau-jll, julia-xorg-libxcb-jll, julia-xorg-libxcursor-jll, julia-xorg-libxdmcp-jll, julia-xorg-libxext-jll, julia-xorg-libxfixes-jll, julia-xorg-libxi-jll, julia-xorg-libxinerama-jll, julia-xorg-libxkbfile-jll, julia-xorg-libxrandr-jll, julia-xorg-libxrender-jll, julia-xorg-xcb-util-jll, julia-xorg-xcb-util-keysyms-jll, julia-xorg-xcb-util-renderutil-jll, julia-xorg-xcb-util-wm-jll, julia-xorg-xkbcomp-jll, julia-xorg-xkeyboard-config-jll, julia-xorg-xtrans-jll, julia-xslt-jll, julia-zlib-jll, julia-zstd-jll) [argument]: Adjust the order of the phases to the change in the julia-build-system. * gnu/packages/julia-xyz.scm (julia-bufferedstreams, julia-calculus, julia-dataframes, julia-datavalues, julia-distances, julia-documenter, julia-dualnumbers, julia-ellipsisnotation, julia-expronicon, julia-fileio, julia-fixedpointnumbers, julia-functionwrappers, julia-fuzzycompletions, julia-genericlinearalgebra, julia-genericschur, julia-geometrybasics, julia-imagemagick, julia-infinity, julia-matrixfactorizations, julia-media, julia-missings, julia-nnlib, julia-optimtestproblems, julia-orderedcollections, julia-prettytables, julia-pycall, julia-quadmath, julia-safetests, julia-stackviews) [arguments]: Correct paths to reflect change of %package-path modify order of phases as link-depot needs to run on an unmodified src directory add package-name-uuid keyword argument to packages without Project.toml file. * gnu/packages/julia.scm (julia)[native-search-paths]: Correct paths to reflect change of %package-path modify order of phases as link-depot needs to run on an unmodified src directory. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages')
-rw-r--r--gnu/packages/julia-jll.scm138
-rw-r--r--gnu/packages/julia-xyz.scm69
-rw-r--r--gnu/packages/julia.scm2
3 files changed, 107 insertions, 102 deletions
diff --git a/gnu/packages/julia-jll.scm b/gnu/packages/julia-jll.scm
index 51643819ae..d8cf5b9eaf 100644
--- a/gnu/packages/julia-jll.scm
+++ b/gnu/packages/julia-jll.scm
@@ -77,7 +77,7 @@
'(#:tests? #f ; No runtests.jl
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'override-binary-path
+ (add-after 'link-depot 'override-binary-path
(lambda* (#:key inputs #:allow-other-keys)
(map
(lambda (wrapper)
@@ -117,7 +117,7 @@ compression program.")
'(#:tests? #f ; no runtests
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'override-binary-path
+ (add-after 'link-depot 'override-binary-path
(lambda* (#:key inputs #:allow-other-keys)
(map
(lambda (wrapper)
@@ -163,7 +163,7 @@ compression program.")
`(#:tests? #f ; no runtests.jl
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'override-binary-path
+ (add-after 'link-depot 'override-binary-path
(lambda* (#:key inputs #:allow-other-keys)
(map
(lambda (wrapper)
@@ -205,7 +205,7 @@ build tree Yggdrasil.")
'(#:tests? #f ; no runtests
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'override-binary-path
+ (add-after 'link-depot 'override-binary-path
(lambda* (#:key inputs #:allow-other-keys)
(map
(lambda (wrapper)
@@ -243,7 +243,7 @@ build tree Yggdrasil.")
'(#:tests? #f ; no runtests
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'override-binary-path
+ (add-after 'link-depot 'override-binary-path
(lambda* (#:key inputs #:allow-other-keys)
(map
(lambda (wrapper)
@@ -292,7 +292,7 @@ build tree Yggdrasil.")
'(#:tests? #f ; no runtests
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'override-binary-path
+ (add-after 'link-depot 'override-binary-path
(lambda* (#:key inputs #:allow-other-keys)
(map
(lambda (wrapper)
@@ -335,7 +335,7 @@ build tree Yggdrasil.")
'(#:tests? #f ; No runtests.jl
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'override-binary-path
+ (add-after 'link-depot 'override-binary-path
(lambda* (#:key inputs #:allow-other-keys)
(map
(lambda (wrapper)
@@ -377,7 +377,7 @@ rendering library.")
'(#:tests? #f ; no runtests
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'override-binary-path
+ (add-after 'link-depot 'override-binary-path
(lambda* (#:key inputs #:allow-other-keys)
(map
(lambda (wrapper)
@@ -413,7 +413,7 @@ rendering library.")
'(#:tests? #f ; no runtests
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'override-binary-path
+ (add-after 'link-depot 'override-binary-path
(lambda* (#:key inputs #:allow-other-keys)
(map
(lambda (wrapper)
@@ -454,7 +454,7 @@ rendering library.")
'(#:tests? #f ; no runtests
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'override-binary-path
+ (add-after 'link-depot 'override-binary-path
(lambda* (#:key inputs #:allow-other-keys)
(map
(lambda (wrapper)
@@ -497,7 +497,7 @@ rendering library.")
'(#:tests? #f ; no runtests
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'override-binary-path
+ (add-after 'link-depot 'override-binary-path
(lambda* (#:key inputs #:allow-other-keys)
(map
(lambda (wrapper)
@@ -541,7 +541,7 @@ rendering library.")
'(#:tests? #f ; no runtests
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'override-binary-path
+ (add-after 'link-depot 'override-binary-path
(lambda* (#:key inputs #:allow-other-keys)
(map
(lambda (wrapper)
@@ -590,7 +590,7 @@ rendering library.")
'(#:tests? #f ; no runtests
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'override-binary-path
+ (add-after 'link-depot 'override-binary-path
(lambda* (#:key inputs #:allow-other-keys)
(let ((gumbo (string-append (assoc-ref inputs "gumbo-parser"))))
(for-each
@@ -630,7 +630,7 @@ rendering library.")
'(#:tests? #f ; no runtests
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'override-binary-path
+ (add-after 'link-depot 'override-binary-path
(lambda* (#:key inputs #:allow-other-keys)
(map
(lambda (wrapper)
@@ -672,7 +672,7 @@ rendering library.")
'(#:tests? #f
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'custom-override-path
+ (add-after 'link-depot 'custom-override-path
(lambda* (#:key inputs #:allow-other-keys)
;; Make @generate_wrapper_header take an optional argument that
;; guix packagers can pass to override the default "override"
@@ -718,7 +718,7 @@ used in autogenerated packages via @code{BinaryBuilder.jl}.")
'(#:tests? #f ; no runtests
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'override-binary-path
+ (add-after 'link-depot 'override-binary-path
(lambda* (#:key inputs #:allow-other-keys)
(map
(lambda (wrapper)
@@ -754,7 +754,7 @@ used in autogenerated packages via @code{BinaryBuilder.jl}.")
'(#:tests? #f ; no runtests
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'override-binary-path
+ (add-after 'link-depot 'override-binary-path
(lambda* (#:key inputs #:allow-other-keys)
(map
(lambda (wrapper)
@@ -790,7 +790,7 @@ used in autogenerated packages via @code{BinaryBuilder.jl}.")
'(#:tests? #f ; no runtests
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'override-binary-path
+ (add-after 'link-depot 'override-binary-path
(lambda* (#:key inputs #:allow-other-keys)
(map
(lambda (wrapper)
@@ -830,7 +830,7 @@ used in autogenerated packages via @code{BinaryBuilder.jl}.")
'(#:tests? #f ; no runtests
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'override-binary-path
+ (add-after 'link-depot 'override-binary-path
(lambda* (#:key inputs #:allow-other-keys)
(map
(lambda (wrapper)
@@ -866,7 +866,7 @@ used in autogenerated packages via @code{BinaryBuilder.jl}.")
'(#:tests? #f ; no runtests
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'override-binary-path
+ (add-after 'link-depot 'override-binary-path
(lambda* (#:key inputs #:allow-other-keys)
(map
(lambda (wrapper)
@@ -903,7 +903,7 @@ used in autogenerated packages via @code{BinaryBuilder.jl}.")
'(#:tests? #f ; no runtests
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'override-binary-path
+ (add-after 'link-depot 'override-binary-path
(lambda* (#:key inputs #:allow-other-keys)
(map
(lambda (wrapper)
@@ -942,7 +942,7 @@ used in autogenerated packages via @code{BinaryBuilder.jl}.")
'(#:tests? #f ; no runtests
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'override-binary-path
+ (add-after 'link-depot 'override-binary-path
(lambda* (#:key inputs #:allow-other-keys)
(map
(lambda (wrapper)
@@ -980,7 +980,7 @@ used in autogenerated packages via @code{BinaryBuilder.jl}.")
'(#:tests? #f ; no runtests
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'override-binary-path
+ (add-after 'link-depot 'override-binary-path
(lambda* (#:key inputs #:allow-other-keys)
(map
(lambda (wrapper)
@@ -1018,7 +1018,7 @@ used in autogenerated packages via @code{BinaryBuilder.jl}.")
'(#:tests? #f ; no runtests
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'override-binary-path
+ (add-after 'link-depot 'override-binary-path
(lambda* (#:key inputs #:allow-other-keys)
(map
(lambda (wrapper)
@@ -1056,7 +1056,7 @@ used in autogenerated packages via @code{BinaryBuilder.jl}.")
'(#:tests? #f ; no runtests
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'override-binary-path
+ (add-after 'link-depot 'override-binary-path
(lambda* (#:key inputs #:allow-other-keys)
(map
(lambda (wrapper)
@@ -1095,7 +1095,7 @@ from util-linux.")
'(#:tests? #f ; no runtests
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'override-binary-path
+ (add-after 'link-depot 'override-binary-path
(lambda* (#:key inputs #:allow-other-keys)
(map
(lambda (wrapper)
@@ -1133,7 +1133,7 @@ from util-linux.")
`(#:tests? #f ; no runtests.jl
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'override-binary-path
+ (add-after 'link-depot 'override-binary-path
(lambda* (#:key inputs #:allow-other-keys)
(map
(lambda (wrapper)
@@ -1175,7 +1175,7 @@ build tree Yggdrasil.")
'(#:tests? #f ; no runtests
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'override-binary-path
+ (add-after 'link-depot 'override-binary-path
(lambda* (#:key inputs #:allow-other-keys)
(map
(lambda (wrapper)
@@ -1214,7 +1214,7 @@ build tree Yggdrasil.")
'(#:tests? #f ; no runtests
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'override-binary-path
+ (add-after 'link-depot 'override-binary-path
(lambda* (#:key inputs #:allow-other-keys)
(map
(lambda (wrapper)
@@ -1252,7 +1252,7 @@ build tree Yggdrasil.")
'(#:tests? #f ; no runtests
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'override-binary-path
+ (add-after 'link-depot 'override-binary-path
(lambda* (#:key inputs #:allow-other-keys)
(map
(lambda (wrapper)
@@ -1290,7 +1290,7 @@ build tree Yggdrasil.")
'(#:tests? #f ; no runtests
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'override-binary-path
+ (add-after 'link-depot 'override-binary-path
(lambda* (#:key inputs #:allow-other-keys)
(map
(lambda (wrapper)
@@ -1328,7 +1328,7 @@ build tree Yggdrasil.")
'(#:tests? #f ; No runtests.jl
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'override-binary-path
+ (add-after 'link-depot 'override-binary-path
(lambda* (#:key inputs #:allow-other-keys)
(map
(lambda (wrapper)
@@ -1366,7 +1366,7 @@ wrappers.")
'(#:tests? #f ; no runtests
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'override-binary-path
+ (add-after 'link-depot 'override-binary-path
(lambda* (#:key inputs #:allow-other-keys)
(map
(lambda (wrapper)
@@ -1403,7 +1403,7 @@ wrappers.")
`(#:tests? #f ; no runtests.jl
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'override-binary-path
+ (add-after 'link-depot 'override-binary-path
(lambda* (#:key inputs #:allow-other-keys)
(map
(lambda (wrapper)
@@ -1446,7 +1446,7 @@ build tree Yggdrasil.")
'(#:tests? #f ; no runtests
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'override-binary-path
+ (add-after 'link-depot 'override-binary-path
(lambda* (#:key inputs #:allow-other-keys)
(map
(lambda (wrapper)
@@ -1482,7 +1482,7 @@ build tree Yggdrasil.")
'(#:tests? #f ; no runtests
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'override-binary-path
+ (add-after 'link-depot 'override-binary-path
(lambda* (#:key inputs #:allow-other-keys)
(map
(lambda (wrapper)
@@ -1518,7 +1518,7 @@ build tree Yggdrasil.")
'(#:tests? #f ; no runtests
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'override-binary-path
+ (add-after 'link-depot 'override-binary-path
(lambda* (#:key inputs #:allow-other-keys)
(map
(lambda (wrapper)
@@ -1556,7 +1556,7 @@ build tree Yggdrasil.")
'(#:tests? #f ; no runtests
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'override-binary-path
+ (add-after 'link-depot 'override-binary-path
(lambda* (#:key inputs #:allow-other-keys)
(map
(lambda (wrapper)
@@ -1594,7 +1594,7 @@ build tree Yggdrasil.")
'(#:tests? #f ; no runtests
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'override-binary-path
+ (add-after 'link-depot 'override-binary-path
(lambda* (#:key inputs #:allow-other-keys)
(map
(lambda (wrapper)
@@ -1645,7 +1645,7 @@ build tree Yggdrasil.")
'(#:tests? #f ; no runtests
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'override-binary-path
+ (add-after 'link-depot 'override-binary-path
(lambda* (#:key inputs #:allow-other-keys)
(map
(lambda (wrapper)
@@ -1684,7 +1684,7 @@ build tree Yggdrasil.")
'(#:tests? #f ; no runtests
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'override-binary-path
+ (add-after 'link-depot 'override-binary-path
(lambda* (#:key inputs #:allow-other-keys)
(map
(lambda (wrapper)
@@ -1721,7 +1721,7 @@ build tree Yggdrasil.")
`(#:tests? #f ; no runtests
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'override-binary-path
+ (add-after 'link-depot 'override-binary-path
(lambda* (#:key inputs #:allow-other-keys)
(let ((libx264 (assoc-ref inputs "libx264")))
(map
@@ -1762,7 +1762,7 @@ build tree Yggdrasil.")
'(#:tests? #f ; no runtests
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'override-binary-path
+ (add-after 'link-depot 'override-binary-path
(lambda* (#:key inputs #:allow-other-keys)
(map
(lambda (wrapper)
@@ -1798,7 +1798,7 @@ build tree Yggdrasil.")
'(#:tests? #f ; no runtests
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'override-binary-path
+ (add-after 'link-depot 'override-binary-path
(lambda* (#:key inputs #:allow-other-keys)
(map
(lambda (wrapper)
@@ -1838,7 +1838,7 @@ build tree Yggdrasil.")
'(#:tests? #f ; no runtests
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'override-binary-path
+ (add-after 'link-depot 'override-binary-path
(lambda* (#:key inputs #:allow-other-keys)
(map
(lambda (wrapper)
@@ -1878,7 +1878,7 @@ build tree Yggdrasil.")
'(#:tests? #f ; no runtests
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'override-binary-path
+ (add-after 'link-depot 'override-binary-path
(lambda* (#:key inputs #:allow-other-keys)
(map
(lambda (wrapper)
@@ -1915,7 +1915,7 @@ build tree Yggdrasil.")
'(#:tests? #f ; no runtests
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'override-binary-path
+ (add-after 'link-depot 'override-binary-path
(lambda* (#:key inputs #:allow-other-keys)
(map
(lambda (wrapper)
@@ -1953,7 +1953,7 @@ build tree Yggdrasil.")
'(#:tests? #f ; no runtests
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'override-binary-path
+ (add-after 'link-depot 'override-binary-path
(lambda* (#:key inputs #:allow-other-keys)
(map
(lambda (wrapper)
@@ -1989,7 +1989,7 @@ build tree Yggdrasil.")
'(#:tests? #f ; no runtests
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'override-binary-path
+ (add-after 'link-depot 'override-binary-path
(lambda* (#:key inputs #:allow-other-keys)
(map
(lambda (wrapper)
@@ -2029,7 +2029,7 @@ build tree Yggdrasil.")
'(#:tests? #f ; no runtests
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'override-binary-path
+ (add-after 'link-depot 'override-binary-path
(lambda* (#:key inputs #:allow-other-keys)
(map
(lambda (wrapper)
@@ -2067,7 +2067,7 @@ build tree Yggdrasil.")
'(#:tests? #f ; no runtests
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'override-binary-path
+ (add-after 'link-depot 'override-binary-path
(lambda* (#:key inputs #:allow-other-keys)
(map
(lambda (wrapper)
@@ -2103,7 +2103,7 @@ build tree Yggdrasil.")
'(#:tests? #f ; no runtests
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'override-binary-path
+ (add-after 'link-depot 'override-binary-path
(lambda* (#:key inputs #:allow-other-keys)
(map
(lambda (wrapper)
@@ -2140,7 +2140,7 @@ build tree Yggdrasil.")
'(#:tests? #f ; no runtests
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'override-binary-path
+ (add-after 'link-depot 'override-binary-path
(lambda* (#:key inputs #:allow-other-keys)
(map
(lambda (wrapper)
@@ -2177,7 +2177,7 @@ build tree Yggdrasil.")
'(#:tests? #f ; no runtests
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'override-binary-path
+ (add-after 'link-depot 'override-binary-path
(lambda* (#:key inputs #:allow-other-keys)
(map
(lambda (wrapper)
@@ -2215,7 +2215,7 @@ build tree Yggdrasil.")
'(#:tests? #f ; no runtests
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'override-binary-path
+ (add-after 'link-depot 'override-binary-path
(lambda* (#:key inputs #:allow-other-keys)
(map
(lambda (wrapper)
@@ -2252,7 +2252,7 @@ build tree Yggdrasil.")
'(#:tests? #f ; no runtests
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'override-binary-path
+ (add-after 'link-depot 'override-binary-path
(lambda* (#:key inputs #:allow-other-keys)
(map
(lambda (wrapper)
@@ -2289,7 +2289,7 @@ build tree Yggdrasil.")
'(#:tests? #f ; no runtests
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'override-binary-path
+ (add-after 'link-depot 'override-binary-path
(lambda* (#:key inputs #:allow-other-keys)
(map
(lambda (wrapper)
@@ -2327,7 +2327,7 @@ build tree Yggdrasil.")
'(#:tests? #f ; no runtests
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'override-binary-path
+ (add-after 'link-depot 'override-binary-path
(lambda* (#:key inputs #:allow-other-keys)
(map
(lambda (wrapper)
@@ -2364,7 +2364,7 @@ build tree Yggdrasil.")
'(#:tests? #f ; no runtests
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'override-binary-path
+ (add-after 'link-depot 'override-binary-path
(lambda* (#:key inputs #:allow-other-keys)
(map
(lambda (wrapper)
@@ -2401,7 +2401,7 @@ build tree Yggdrasil.")
'(#:tests? #f ; no runtests
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'override-binary-path
+ (add-after 'link-depot 'override-binary-path
(lambda* (#:key inputs #:allow-other-keys)
(map
(lambda (wrapper)
@@ -2438,7 +2438,7 @@ build tree Yggdrasil.")
'(#:tests? #f ; no runtests
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'override-binary-path
+ (add-after 'link-depot 'override-binary-path
(lambda* (#:key inputs #:allow-other-keys)
(map
(lambda (wrapper)
@@ -2475,7 +2475,7 @@ build tree Yggdrasil.")
'(#:tests? #f ; no runtests
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'override-binary-path
+ (add-after 'link-depot 'override-binary-path
(lambda* (#:key inputs #:allow-other-keys)
(map
(lambda (wrapper)
@@ -2512,7 +2512,7 @@ build tree Yggdrasil.")
'(#:tests? #f ; no runtests
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'override-binary-path
+ (add-after 'link-depot 'override-binary-path
(lambda* (#:key inputs #:allow-other-keys)
(map
(lambda (wrapper)
@@ -2549,7 +2549,7 @@ build tree Yggdrasil.")
'(#:tests? #f ; no runtests
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'override-binary-path
+ (add-after 'link-depot 'override-binary-path
(lambda* (#:key inputs #:allow-other-keys)
(map
(lambda (wrapper)
@@ -2586,7 +2586,7 @@ build tree Yggdrasil.")
'(#:tests? #f ; no runtests
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'override-binary-path
+ (add-after 'link-depot 'override-binary-path
(lambda* (#:key inputs #:allow-other-keys)
(map
(lambda (wrapper)
@@ -2623,7 +2623,7 @@ build tree Yggdrasil.")
'(#:tests? #f ; no runtests
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'override-binary-path
+ (add-after 'link-depot 'override-binary-path
(lambda* (#:key inputs #:allow-other-keys)
(map
(lambda (wrapper)
@@ -2659,7 +2659,7 @@ build tree Yggdrasil.")
'(#:tests? #f ; no runtests
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'override-binary-path
+ (add-after 'link-depot 'override-binary-path
(lambda* (#:key inputs #:allow-other-keys)
(map
(lambda (wrapper)
@@ -2702,7 +2702,7 @@ build tree Yggdrasil.")
'(#:tests? #f ; no runtests
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'override-binary-path
+ (add-after 'link-depot 'override-binary-path
(lambda* (#:key inputs #:allow-other-keys)
(map
(lambda (wrapper)
@@ -2740,7 +2740,7 @@ build tree Yggdrasil.")
'(#:tests? #f ; no runtests
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'override-binary-path
+ (add-after 'link-depot 'override-binary-path
(lambda* (#:key inputs #:allow-other-keys)
(map
(lambda (wrapper)
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index 93fadf318c..73768317b8 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -410,7 +410,8 @@ structures.")
;; https://travis-ci.org/BioJulia/BufferedStreams.jl/jobs/491050182
(arguments
'(#:tests? #f
- #:julia-package-name "BufferedStreams"))
+ #:julia-package-name "BufferedStreams"
+ #:julia-package-uuid "e1450e63-4bb3-523b-b2a4-4ffa8c0fd77d"))
(propagated-inputs `(("julia-compat" ,julia-compat)))
(home-page "https://github.com/BioJulia/BufferedStreams.jl")
(synopsis "Fast composable IO streams")
@@ -778,12 +779,12 @@ way.")
(arguments
`(#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'fix-tests
+ (add-after 'link-depot 'fix-tests
(lambda _
(substitute* "test/runtests.jl"
(("option.toml") "test/option.toml"))
#t))
- (add-after 'unpack 'dont-use-exproniconlite
+ (add-after 'link-depot 'dont-use-exproniconlite
(lambda _
(substitute* '("Project.toml"
"src/Configurations.jl"
@@ -919,7 +920,7 @@ dependency on it.")
(arguments
`(#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'skip-failing-test
+ (add-after 'link-depot 'skip-failing-test
(lambda _
;; Tests with non-standard colors.
(substitute* "test/show.jl"
@@ -1022,7 +1023,7 @@ without having to take direct dependencies.")
`(#:tests? #f ; Tests need upgrading with newer Julia version.
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'skip-known-failing-tests
+ (add-after 'link-depot 'skip-known-failing-tests
(lambda _
;; See upstream report:
;; https://github.com/queryverse/DataValues.jl/issues/83
@@ -1100,7 +1101,7 @@ dictionaries in Julia, for improved productivity and performance.")
(arguments
`(#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'skip-flakey-tests
+ (add-after 'link-depot 'skip-flakey-tests
(lambda _
;; Some combination of these tests fail nondeterministically
;; each of the times this package is built.
@@ -1166,14 +1167,14 @@ valuable enough at this time.")
(arguments
`(#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'patch-source
+ (add-after 'link-depot 'patch-source
(lambda* (#:key inputs #:allow-other-keys)
(substitute* "src/Deps.jl"
(("pip install")
(string-append (assoc-ref inputs "python")
"/bin/pip install")))
#t))
- (add-after 'unpack 'remove-javascript-downloads
+ (add-after 'link-depot 'remove-javascript-downloads
(lambda _
(substitute* "src/Writers/HTMLWriter.jl"
(("cdnjs.cloudflare.com") "example.com"))
@@ -1352,7 +1353,7 @@ stressing the robustness of differentiation tools.")
(arguments
`(#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'adjust-test-suite
+ (add-after 'link-depot 'adjust-test-suite
(lambda _
(substitute* "test/runtests.jl"
;; Seems to not play nicely with SpecialFunctions
@@ -1386,7 +1387,7 @@ combinations of dual numbers with predefined Julia numeric types.")
(arguments
`(#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'adjust-test-suite
+ (add-after 'link-depot 'adjust-test-suite
(lambda _
(substitute* "test/runtests.jl"
;; Seems to not play nicely with Julia-1.6.
@@ -1438,7 +1439,7 @@ before (or after)\".")
(arguments
`(#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'skip-network-tests
+ (add-after 'link-depot 'skip-network-tests
(lambda _
(substitute* "test/runtests.jl"
;; This test tries to access the Julia package registry.
@@ -1517,7 +1518,7 @@ need the ffmpeg binaries + executables, and don't want the overhead of
`(#:phases
(modify-phases %standard-phases
(delete 'reset-gzip-timestamps)
- (add-after 'unpack 'skip-network-tests
+ (add-after 'link-depot 'skip-network-tests
(lambda _
;; These tests try to download audio/video files.
(substitute* "test/query.jl"
@@ -1677,7 +1678,7 @@ using finite difference.")
(arguments
`(#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'disable-failing-test
+ (add-after 'link-depot 'disable-failing-test
(lambda* (#:key outputs #:allow-other-keys)
(substitute* "test/fixed.jl"
;; A deprecation warning is not thrown
@@ -1764,7 +1765,7 @@ differentiation (AD).")
(arguments
`(#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'adjust-tests
+ (add-after 'link-depot 'adjust-tests
(lambda _
(substitute* "test/runtests.jl"
(("testset \\\"Abstract.*" all)
@@ -1817,7 +1818,7 @@ update step.")
(arguments
`(#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'skip-failing-test
+ (add-after 'link-depot 'skip-failing-test
(lambda _
(substitute* "test/runtests.jl"
((".*RPLE.*") "")))))))
@@ -1844,7 +1845,7 @@ update step.")
(arguments
`(#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'adjust-test-suite
+ (add-after 'link-depot 'adjust-test-suite
(lambda _
(substitute* "test/runtests.jl"
((".*lapack.*") "")))))))
@@ -1875,7 +1876,7 @@ algebra routines written in Julia (except for optimized BLAS).")
(arguments
`(#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'adjust-test-suite
+ (add-after 'link-depot 'adjust-test-suite
(lambda _
(substitute* "test/complex.jl"
;; expected Array{Int32,1}, got a value of type Array{Int64,1}
@@ -1912,13 +1913,13 @@ matrices the Schur form is often more useful.")
(arguments
`(#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'remove-earcut
+ (add-after 'link-depot 'remove-earcut
(lambda _
(substitute* '("Project.toml"
"src/GeometryBasics.jl")
((".*EarCut.*") ""))
#t))
- (add-after 'unpack 'skip-incompatible-test
+ (add-after 'link-depot 'skip-incompatible-test
(lambda _
(substitute* "test/runtests.jl"
(("@testset.*MetaT and heterogeneous data.*" all)
@@ -2268,7 +2269,7 @@ be downscaled to fit into the size of your active terminal session.")
(arguments
`(#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'skip-failing-test
+ (add-after 'link-depot 'skip-failing-test
(lambda _
;; These tests try to download from the imagemagick.org
(substitute* "test/runtests.jl"
@@ -2465,7 +2466,7 @@ indexed images, sometimes called \"colormap images\" or \"paletted images.\"")
(arguments
`(#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'remove-timezones.jl
+ (add-after 'link-depot 'remove-timezones.jl
(lambda _
(substitute* "test/runtests.jl"
(("using TimeZones.*") "")
@@ -2864,7 +2865,7 @@ comes from the fact that @code{M == map(f, A)}.")
(arguments
`(#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'skip-failing-test
+ (add-after 'link-depot 'skip-failing-test
(lambda _
;; Tests with math functions are hard.
(substitute* "test/test_ul.jl"
@@ -2981,7 +2982,8 @@ resolving them into absolute units.")
(build-system julia-build-system)
;; Package without Project.toml
(arguments
- '(#:julia-package-name "Media"))
+ '(#:julia-package-name "Media"
+ #:julia-package-uuid "e89f7d12-3494-54d1-8411-f7d8b9ae1f27"))
(propagated-inputs
`(("julia-macrotools" ,julia-macrotools)))
(home-page "https://github.com/JunoLab/Media.jl")
@@ -3202,7 +3204,7 @@ interface to interact with these types.")
(arguments
`(#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'skip-cuda-tests
+ (add-after 'link-depot 'skip-cuda-tests
(lambda _
(substitute* "test/runtests.jl"
(("using CUDA") "")
@@ -3238,7 +3240,8 @@ doesn't provide any other \"high-level\" functionality like layers or AD.")
(base32 "10h47x5ws42pkqjccimaz0yxfvz41w0yazq6inamfk4lg5g2g3d9"))))
(build-system julia-build-system)
(arguments
- `(#:julia-package-name "OptimTestProblems"))
+ `(#:julia-package-name "OptimTestProblems"
+ #:julia-package-uuid "cec144fc-5a64-5bc6-99fb-dde8f63e154c"))
(home-page "https://github.com/JuliaNLSolvers/OptimTestProblems.jl")
(synopsis "Collection of optimization test problems")
(description "The purpose of this package is to provide test problems for
@@ -3528,7 +3531,7 @@ everything from run time algorithm choice to code generation at compile time.")
(arguments
`(#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'skip-color-tests
+ (add-after 'link-depot 'skip-color-tests
(lambda _
(substitute* "test/text_backend.jl"
((".*colors\\.jl.*") ""))
@@ -3567,7 +3570,7 @@ human-readable format.")
((guix build python-build-system) #:prefix python:))
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'remove-conda
+ (add-after 'link-depot 'remove-conda
(lambda _
(substitute* "Project.toml"
((".*Conda.*") ""))
@@ -3577,7 +3580,7 @@ human-readable format.")
(substitute* "deps/depsutils.jl"
(("Conda.PYTHONDIR") "\"/\""))
#t))
- (add-after 'unpack 'set-python
+ (add-after 'link-depot 'set-python
(lambda* (#:key inputs outputs #:allow-other-keys)
(let ((python (assoc-ref inputs "python")))
(setenv "PYCALL_JL_RUNTIME_PYTHON"
@@ -3690,7 +3693,7 @@ arbitrary normed vector spaces (e.g. matrix-valued integrands).")
(arguments
`(#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'hardcode-libmath-location
+ (add-after 'link-depot 'hardcode-libmath-location
(lambda* (#:key inputs #:allow-other-keys)
(let ((gcclib (assoc-ref inputs "gcc:lib")))
(substitute* "src/Quadmath.jl"
@@ -4082,7 +4085,8 @@ through matrix-vector multiplication.")
(base32 "1fb1dfdmiw2ggx60hf70954xlps0r48fcb3k3dvxynlz7ylphp96"))))
(build-system julia-build-system)
(arguments
- `(#:julia-package-name "SafeTestsets"))
+ `(#:julia-package-name "SafeTestsets"
+ #:julia-package-uuid "1bc83da4-3b8d-516f-aca4-4fe02f6d838f"))
(native-inputs
`(("julia-staticarrays" ,julia-staticarrays)))
(home-page "https://github.com/YingboMa/SafeTestsets.jl")
@@ -4308,7 +4312,7 @@ some performance improvements).")
(arguments
`(#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'skip-doctest
+ (add-after 'link-depot 'skip-doctest
(lambda _
(substitute* "test/runtests.jl"
((".*doctest.*") ""))
@@ -4811,6 +4815,7 @@ types, modules, and dictionaries.")
(build-system julia-build-system)
(arguments
'(#:julia-package-name "URIs" ;required to run tests
+ #:julia-package-uuid "5c2747f8-b7ea-4ff2-ba2e-563bfd36b1d4"
#:phases
(modify-phases %standard-phases
(add-before 'check 'change-dir
@@ -4818,7 +4823,7 @@ types, modules, and dictionaries.")
(lambda* (#:key source outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out")))
(chdir
- (string-append out "/share/julia/packages/URIs/test")))
+ (string-append out "/share/julia/loadpath/URIs/test")))
#t)))))
;; required for tests
(inputs `(("julia-json" ,julia-json)))
diff --git a/gnu/packages/julia.scm b/gnu/packages/julia.scm
index 411f2e2e10..5b9bf91ed6 100644
--- a/gnu/packages/julia.scm
+++ b/gnu/packages/julia.scm
@@ -673,7 +673,7 @@ libraries. It is also a bit like @code{ldd} and @code{otool -L}.")
(native-search-paths
(list (search-path-specification
(variable "JULIA_LOAD_PATH")
- (files (list "share/julia/packages/")))
+ (files (list "share/julia/loadpath/")))
(search-path-specification
(variable "JULIA_DEPOT_PATH")
(files (list "share/julia/")))))