summaryrefslogtreecommitdiff
path: root/gnu/packages/irc.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-11-21 13:41:31 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2020-11-21 23:00:06 +0100
commitfb71e5a83d317217c3d9d93fe9bbb49cc399fa10 (patch)
tree97ed208761a0e5f7702e53f33f67d5f694fe3d4a /gnu/packages/irc.scm
parent1bf139947e2dd6d8eb15e9006d0097070fdcfe2b (diff)
downloadguix-patches-fb71e5a83d317217c3d9d93fe9bbb49cc399fa10.tar
guix-patches-fb71e5a83d317217c3d9d93fe9bbb49cc399fa10.tar.gz
gnu: inspircd: Make most inputs non-native.
* gnu/packages/irc.scm (inspircd)[native-inputs]: Reduce to pkg-config. Move the rest… [inputs]: …here.
Diffstat (limited to 'gnu/packages/irc.scm')
-rw-r--r--gnu/packages/irc.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/irc.scm b/gnu/packages/irc.scm
index 48ed9c0db5..c102e73cc6 100644
--- a/gnu/packages/irc.scm
+++ b/gnu/packages/irc.scm
@@ -549,15 +549,16 @@ interface for those who are accustomed to the ircII way of doing things.")
(string-append "--config-dir=" out-etc name)))
#t)))))
(native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (inputs
`(("gnutls" ,gnutls)
("libmaxminddb" ,libmaxminddb)
- ("mysql" ,mysql)
("mbedtls-apache" ,mbedtls-apache)
+ ("mysql" ,mysql)
("openldap" ,openldap)
("openssl" ,openssl)
("pcre" ,pcre "bin")
("perl" ,perl)
- ("pkg-config" ,pkg-config)
("postgresql" ,postgresql)
("re2" ,re2)
("sqlite" ,sqlite)