summaryrefslogtreecommitdiff
path: root/gnu/packages/imagemagick.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2020-11-11 21:33:04 +0100
committerMarius Bakke <marius@gnu.org>2020-11-11 21:35:32 +0100
commit4688dc9bb89a3b753edcbcfb6bcd5ef0df69e584 (patch)
treeb97117725585ed5908108f2f8af94cb10cfb459e /gnu/packages/imagemagick.scm
parenta9a0d348743af1a25fd27b2b073f0fe2b46978b6 (diff)
downloadguix-patches-4688dc9bb89a3b753edcbcfb6bcd5ef0df69e584.tar
guix-patches-4688dc9bb89a3b753edcbcfb6bcd5ef0df69e584.tar.gz
gnu: transcode: Build with a newer ImageMagick.
* gnu/packages/imagemagick.scm (imagemagick-next): New public variable. * gnu/packages/video.scm (transcode)[inputs]: Change from IMAGEMAGICK to IMAGEMAGICK-NEXT.
Diffstat (limited to 'gnu/packages/imagemagick.scm')
-rw-r--r--gnu/packages/imagemagick.scm15
1 files changed, 15 insertions, 0 deletions
diff --git a/gnu/packages/imagemagick.scm b/gnu/packages/imagemagick.scm
index e4efea4e45..a624d7bc6a 100644
--- a/gnu/packages/imagemagick.scm
+++ b/gnu/packages/imagemagick.scm
@@ -7,6 +7,7 @@
;;; Copyright © 2017 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018 Alex Vong <alexvong1995@gmail.com>
+;;; Copyright © 2020 Marius Bakke <marius@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -124,6 +125,20 @@ transform images, adjust image colors, apply various special effects, or draw
text, lines, polygons, ellipses and Bézier curves.")
(license (license:fsf-free "http://www.imagemagick.org/script/license.php"))))
+;; XXX: 'transcode' fails to detect the above ImageMagick, so we provide
+;; this newer version.
+(define-public imagemagick-next
+ (package
+ (inherit imagemagick)
+ (version "6.9.11-37")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://imagemagick/ImageMagick-"
+ version ".tar.xz"))
+ (sha256
+ (base32
+ "19r6fyhr1bycx0p6jz034mil1zh2k7hfr02is40h4g3wf9b9sdni"))))))
+
(define-public perl-image-magick
(package
(name "perl-image-magick")