summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/imagemagick.scm15
-rw-r--r--gnu/packages/video.scm2
2 files changed, 16 insertions, 1 deletions
diff --git a/gnu/packages/imagemagick.scm b/gnu/packages/imagemagick.scm
index e4efea4e45..a624d7bc6a 100644
--- a/gnu/packages/imagemagick.scm
+++ b/gnu/packages/imagemagick.scm
@@ -7,6 +7,7 @@
;;; Copyright © 2017 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018 Alex Vong <alexvong1995@gmail.com>
+;;; Copyright © 2020 Marius Bakke <marius@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -124,6 +125,20 @@ transform images, adjust image colors, apply various special effects, or draw
text, lines, polygons, ellipses and Bézier curves.")
(license (license:fsf-free "http://www.imagemagick.org/script/license.php"))))
+;; XXX: 'transcode' fails to detect the above ImageMagick, so we provide
+;; this newer version.
+(define-public imagemagick-next
+ (package
+ (inherit imagemagick)
+ (version "6.9.11-37")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://imagemagick/ImageMagick-"
+ version ".tar.xz"))
+ (sha256
+ (base32
+ "19r6fyhr1bycx0p6jz034mil1zh2k7hfr02is40h4g3wf9b9sdni"))))))
+
(define-public perl-image-magick
(package
(name "perl-image-magick")
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 60a3928e32..04c3687454 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -245,7 +245,7 @@
("faac" ,faac)
("ffmpeg" ,ffmpeg)
("freetype" ,freetype)
- ("imagemagick" ,imagemagick)
+ ("imagemagick" ,imagemagick-next)
("lame" ,lame)
("liba52" ,liba52)
("libdv" ,libdv)