summaryrefslogtreecommitdiff
path: root/gnu/packages/image.scm
diff options
context:
space:
mode:
authorVagrant Cascadian <vagrant@reproducible-builds.org>2019-09-06 16:48:40 -0700
committerVagrant Cascadian <vagrant@debian.org>2019-09-07 23:44:04 -0700
commitd54ca1cd4d77a945ad07dba34a69c23a3e57b3f1 (patch)
tree15e5f20b4d95b748dfa70938b0db587c0a865678 /gnu/packages/image.scm
parent68fea604b06a6d1d461fa856a6379bb49500fb3b (diff)
downloadguix-patches-d54ca1cd4d77a945ad07dba34a69c23a3e57b3f1.tar
guix-patches-d54ca1cd4d77a945ad07dba34a69c23a3e57b3f1.tar.gz
gnu: Add sng.
* gnu/packages/images (sng): New variable. * gnu/packages/package-management (diffoscope)[native-inputs]: Add sng.
Diffstat (limited to 'gnu/packages/image.scm')
-rw-r--r--gnu/packages/image.scm39
1 files changed, 39 insertions, 0 deletions
diff --git a/gnu/packages/image.scm b/gnu/packages/image.scm
index 433e59c207..2a9ee990be 100644
--- a/gnu/packages/image.scm
+++ b/gnu/packages/image.scm
@@ -1836,3 +1836,42 @@ identical visual appearance.")
to the standard output. It works well together with grim.")
;; MIT license.
(license license:expat)))
+
+(define-public sng
+ (package
+ (name "sng")
+ (version "1.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/sng/sng-"
+ version ".tar.gz"))
+ (sha256
+ (base32 "06a6ydvx9xb3vxvrzdrg3hq0rjwwj9ibr7fyyxjxq6qx1j3mb70i"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-before 'check 'link-pngsuite
+ ;; tests expect pngsuite in source dir
+ (lambda* (#:key inputs #:allow-other-keys)
+ (symlink (assoc-ref inputs "pngsuite") "pngsuite")
+ #t)))
+ #:configure-flags
+ (list (string-append "--with-rgbtxt="
+ (assoc-ref %build-inputs "xorg-rgb")
+ "/share/X11/rgb.txt"))))
+ (inputs `(("xorg-rgb" ,xorg-rgb)
+ ("libpng" ,libpng)))
+ (native-inputs `(("pngsuite" ,pngsuite)))
+ (home-page "http://sng.sourceforge.net")
+ (synopsis "Markup language for representing PNG contents")
+ (description "SNG (Scriptable Network Graphics) is a minilanguage designed
+specifically to represent the entire contents of a PNG (Portable Network
+Graphics) file in an editable form. Thus, SNGs representing elaborate
+graphics images and ancillary chunk data can be readily generated or modified
+using only text tools.
+
+SNG is implemented by a compiler/decompiler called sng that
+losslessly translates between SNG and PNG.")
+ (license license:zlib)))